Page MenuHomePhabricator

anon-meta-packagesProject
ActivePublic

Members (1)

Watchers

  • This project does not have any watchers.

Recent Activity

Fri, Dec 7

Patrick removed a project from T324: Add package needrestart: Whonix 15.
Fri, Dec 7, 11:56 AM · upstream, usability, enhancement, anon-meta-packages, Whonix

Oct 1 2018

Patrick placed T324: Add package needrestart up for grabs.
Oct 1 2018, 1:17 PM · upstream, usability, enhancement, anon-meta-packages, Whonix

Sep 11 2018

Patrick closed T457: install accessibility tools by default as Invalid.
Sep 11 2018, 7:41 PM · Whonix 15, enhancement, usability, anon-meta-packages, Whonix

Aug 8 2018

Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:58 AM · anon-meta-packages, research, Whonix
Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:39 AM · anon-meta-packages, research, Whonix
Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:37 AM · anon-meta-packages, research, Whonix

Jun 30 2018

Patrick added a comment to T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade.

TODO: investigate and scrub leftovers

Jun 30 2018, 12:36 PM · whonix-legacy, Whonix

May 8 2018

Patrick placed T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade up for grabs.
May 8 2018, 9:49 PM · whonix-legacy, Whonix

Apr 6 2018

Patrick closed T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix as Resolved.
In T641#15836, @unman wrote:

Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

Apr 6 2018, 8:34 AM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick updated the task description for T786: consider installing phonon4qt5-backend-null by default on Whonix-Gateway.
Apr 6 2018, 8:32 AM · Whonix, anon-meta-packages, Whonix 15
Patrick triaged T786: consider installing phonon4qt5-backend-null by default on Whonix-Gateway as Normal priority.
Apr 6 2018, 8:30 AM · Whonix, anon-meta-packages, Whonix 15

Apr 4 2018

unman added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

@Patrick
Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

Apr 4 2018, 5:27 PM · Whonix 14, Whonix, anon-meta-packages, Qubes

Mar 14 2018

Patrick assigned T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade to unman.

Looks like nothing serious.

Mar 14 2018, 2:14 PM · whonix-legacy, Whonix
Patrick closed T760: compare ps aux Whonix 13 -> Whonix 14 as Resolved.

Looks like nothing unexpected / nothing need fixing.

Mar 14 2018, 2:10 PM · Whonix 14, anon-meta-packages, Whonix
Patrick closed T761: compare dpkg -l Whonix 13 -> Whonix 14 as Resolved.

Looks like nothing unexpected / nothing need fixing.

Mar 14 2018, 2:09 PM · anon-meta-packages, Whonix, Whonix 14
unman added a comment to T760: compare ps aux Whonix 13 -> Whonix 14.

I have performed a number of upgrades of GW and WS using the latest rc.
I have taken snapshots of running processes, and I would say that (almost) all of the main differences seem to be related to KDE changes between the versions.

Mar 14 2018, 1:52 AM · Whonix 14, anon-meta-packages, Whonix
unman added a comment to T761: compare dpkg -l Whonix 13 -> Whonix 14.

I have run the upgrade a number of times now with the latest rc. update.
There seem to be significant differences between the upgraded 13 and a clean install of 14 - in addition to the architectural changes evident in the move to Stretch.(i386/amd64)
I've attached a summary file of the differences - 14 is generally much cleaner.
The obvious extras included in an upgraded system would seem to be as summarised below. I see loittle differencd between upgraded GW and upgraded WS, in terms of additional programs, drivers and libraries.
KDE stuff:

accountsservice
akonadi-backend-mysql
akonadi-server
anon-kde-streamiso
anon-ws-kde-startmenu
Mar 14 2018, 1:41 AM · anon-meta-packages, Whonix, Whonix 14

Mar 9 2018

unman added a comment to T761: compare dpkg -l Whonix 13 -> Whonix 14.

That's what I thought - the entry in T778 is made on that basis.

Mar 9 2018, 2:19 PM · anon-meta-packages, Whonix, Whonix 14
Patrick added a comment to T761: compare dpkg -l Whonix 13 -> Whonix 14.

Good question.

Mar 9 2018, 12:18 PM · anon-meta-packages, Whonix, Whonix 14
unman added a comment to T761: compare dpkg -l Whonix 13 -> Whonix 14.

Let me check - is this New 14 against upgraded 13, or new 13 against upgraded 13-14?

Mar 9 2018, 3:01 AM · anon-meta-packages, Whonix, Whonix 14
unman added a comment to T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade.

And for GW:

Mar 9 2018, 2:54 AM · whonix-legacy, Whonix
unman added a comment to T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade.

Clean install of 13, and upgraded as per the instructions.
Compared to a clean install of 14:
The significant differences - WS:

UpgradedClean install
SSH_AUTH_SOCK=/tmp/ssh-VznSVpYqegHr/agent.1151
SSH_AGENT_PID=1280
QT_ACCESSIBILITY=1
GTK_MODULES=gail:atk-bridge
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-uWy1DusqXy,guid=899496dd6877f2478d08a7145aa1410eDBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
XDG_CONFIG_DIRS=/usr/share/whonix-ws-kde-desktop-conf/:/usr/share/torbrowser-default-browser/:/usr/share/security-misc/:/usr/share/kde-sounds-off/:/usr/share/kde-privacy/:/usr/share/kde-no-move-max-win/:/usr/share/kde-mouse-doubleclick/:/usr/share/kde-lowfat/:/usr/share/kde-kgpg-tweaks/:/usr/share/kde-dolphin-menubar-enable/:/usr/share/kde-common-resolution/:/usr/share/kde-apper-no-autoupdate/:/usr/share/anon-ws-kde-startmenu/:/usr/share/anon-kde-streamiso/:/usr/share/anon-apps-config/:/usr/share/open-link-confirmation/:/usr/share/kde-power-savings-disable-in-vms/:/usr/share/kde-screen-locker-disable-in-vms/:/etc/xdgXDG_CONFIG_DIRS=/usr/share/torbrowser-default-browser/:/usr/share/security-misc/:/usr/share/kde-apper-no-autoupdate/:/usr/share/anon-ws-kde-startmenu/:/usr/share/anon-apps-config/:/usr/share/open-link-confirmation/:/usr/share/kde-power-savings-disable-in-vms/:/usr/share/kde-screen-locker-disable-in-vms/:/etc/xdg
Mar 9 2018, 2:49 AM · whonix-legacy, Whonix

Mar 7 2018

Patrick added projects to T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade: Whonix 14, anon-meta-packages.
Mar 7 2018, 2:11 AM · whonix-legacy, Whonix
Patrick renamed T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix from install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix to Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.
Mar 7 2018, 1:46 AM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick closed T563: no longer install by default brltty, brltty-speechd, brltty-x11 as Resolved.
Mar 7 2018, 1:10 AM · Whonix, anon-meta-packages, Whonix 14

Jan 21 2018

Patrick closed T422: keep an eye on tor-monitor as Invalid.

Now called onion-circuits which is installed by default in Whonix 14 Gateway.

Jan 21 2018, 1:21 PM · Whonix, anon-meta-packages

Jan 2 2018

Patrick created T761: compare dpkg -l Whonix 13 -> Whonix 14.
Jan 2 2018, 3:29 PM · anon-meta-packages, Whonix, Whonix 14
Patrick added a project to T760: compare ps aux Whonix 13 -> Whonix 14: Whonix 14.
Jan 2 2018, 3:29 PM · Whonix 14, anon-meta-packages, Whonix
Patrick created T760: compare ps aux Whonix 13 -> Whonix 14.
Jan 2 2018, 3:29 PM · Whonix 14, anon-meta-packages, Whonix

Dec 3 2017

Patrick changed the status of T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix from Open to testing-in-next-build-required.

https://github.com/Whonix/qubes-whonix/commit/dac56daeb0fd607a57c0e8e0b85970d31ef6dcee

Dec 3 2017, 2:34 PM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

Not sure how to force installing pulseaudio-qubes on 3.2->4.0 upgrade (instead of keeping old qubes-gui-agent).

Dec 3 2017, 2:21 PM · Whonix 14, Whonix, anon-meta-packages, Qubes

Oct 29 2017

marmarek added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

(highest available version is 3.2.18-1+deb9u1)

Oct 29 2017, 5:53 PM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

True, my suggested solution might work for new builds but might not work
for R3.2 -> R4 upgrades.

Oct 29 2017, 3:21 PM · Whonix 14, Whonix, anon-meta-packages, Qubes

Oct 28 2017

marmarek added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

Will that really works for 4.0? There is also qubes-gui-agent package, so it isn't clear to me that pulseaudio-qubes will really be installed. Perhaps pulseaudio-qubes | qubes-gui-agent (<< 4.0.0)?

Oct 28 2017, 4:52 PM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

It fits well into package qubes-whonix-workstation-packages-recommended.

Oct 28 2017, 4:50 PM · Whonix 14, Whonix, anon-meta-packages, Qubes

Sep 12 2017

Patrick closed T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0 as Resolved.
Sep 12 2017, 2:55 PM · anon-meta-packages, Whonix 14, Whonix, Qubes
marmarek added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.
In T697#14525, @Patrick wrote:

Merged.

Note that I've created PR against Whonix13 branch instead of master intentionally. While it should be mergeable to master too, it would be good to have it in Whonix13. The current version from master branch is already incompatible with Whonix 13.

I couldn't merge / cherry-pick it. Manually emulated.

https://github.com/Whonix/qubes-whonix/commit/9a8d4b94865efceec7928d5498260a44241d96b2

Could you check please the master branch has it all? (Because that will go into Whonix 14.)

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

Sep 12 2017, 3:12 AM · anon-meta-packages, Whonix 14, Whonix, Qubes
Patrick added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.
In T697#14525, @Patrick wrote:

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

Sep 12 2017, 2:58 AM · anon-meta-packages, Whonix 14, Whonix, Qubes
Patrick added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.
Sep 12 2017, 2:57 AM · anon-meta-packages, Whonix 14, Whonix, Qubes

Sep 11 2017

marmarek added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.

Done: https://github.com/Whonix/qubes-whonix/pull/5
Note that I've created PR against Whonix13 branch instead of master intentionally. While it should be mergeable to master too, it would be good to have it in Whonix13. The current version from master branch is already incompatible with Whonix 13.

Sep 11 2017, 9:45 PM · anon-meta-packages, Whonix 14, Whonix, Qubes
Patrick added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.
Sep 11 2017, 6:42 PM · anon-meta-packages, Whonix 14, Whonix, Qubes
marmarek added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.

According to debian policy, << is the syntax for "strictly older than".

Sep 11 2017, 2:59 PM · anon-meta-packages, Whonix 14, Whonix, Qubes
Patrick added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.

From part (<< 4.0.0-1) what does << do?

Sep 11 2017, 2:53 PM · anon-meta-packages, Whonix 14, Whonix, Qubes
marmarek added a comment to T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.

https://github.com/Whonix/qubes-whonix/pull/4

Sep 11 2017, 2:25 AM · anon-meta-packages, Whonix 14, Whonix, Qubes

Jul 7 2017

JasonJAyalaP closed T703: Include Kscreen as Resolved.

I added kscreen to that list:
https://github.com/Whonix/anon-meta-packages/blob/master/debian/control#L148

Jul 7 2017, 7:09 PM · anon-meta-packages, Whonix 14, Whonix

Jul 6 2017

Patrick added a comment to T703: Include Kscreen.

No easy one. Only a hard one.

Jul 6 2017, 6:26 PM · anon-meta-packages, Whonix 14, Whonix
JasonJAyalaP added a comment to T703: Include Kscreen.

Is there an easy way to compare default plasma 5 packages with the ones we're including?

Jul 6 2017, 6:01 PM · anon-meta-packages, Whonix 14, Whonix
Patrick added a comment to T703: Include Kscreen.

Should fit into anon-shared-applications-kde https://github.com/Whonix/anon-meta-packages/blob/master/debian/control#L146?

Jul 6 2017, 2:37 PM · anon-meta-packages, Whonix 14, Whonix
Patrick triaged T703: Include Kscreen as Normal priority.
Jul 6 2017, 2:37 PM · anon-meta-packages, Whonix 14, Whonix

Jun 29 2017

Patrick created T697: sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0.
Jun 29 2017, 6:45 PM · anon-meta-packages, Whonix 14, Whonix, Qubes