Page MenuHomePhabricator

anon-meta-packagesProject
ActivePublic

Members (1)

Watchers

  • This project does not have any watchers.

Recent Activity

Aug 11 2019

Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 11 2019, 2:13 PM · anon-meta-packages, research, Whonix

Aug 9 2019

Patrick added a comment to T215: install electrum bitcoin thin client by default?.

install electrum appimage by default:
https://github.com/Whonix/anon-meta-packages/commit/71d40f5316ee7eb38eb04142d80d23c56a48407b

Aug 9 2019, 11:50 AM · anon-meta-packages, research, Whonix

Jul 27 2019

Patrick added a project to T803: coyIM: Debian version 11 codename Bullseye.
Jul 27 2019, 1:27 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

Jul 25 2019

Patrick updated the task description for T921: Installing git-all will delete some Whonix packages .
Jul 25 2019, 5:08 PM · Whonix
Patrick added a comment to T921: Installing git-all will delete some Whonix packages .

remove qubes-core-agent dependency on initscripts
https://github.com/QubesOS/qubes-issues/issues/5133

Jul 25 2019, 5:08 PM · Whonix
TNTBOMBOM added a comment to T921: Installing git-all will delete some Whonix packages .

but it doesnt happen on plain debian-qubes template , any idea why?

Jul 25 2019, 3:33 PM · Whonix

Jul 22 2019

HulaHoop added a comment to T803: coyIM.

Problem has since been reported and fixed upstream. Let's look into re-including by Bullseye.

Jul 22 2019, 2:35 AM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

Jun 29 2019

marmarek added a comment to T324: Add package needrestart.
In T324#18696, @Patrick wrote:

What is a good way to detect that users are using VM kernel in Qubes? @marmarek If uname -r outputs 4.19.43-1.pvops.qubes.x86_64 i.e. matches *pvops* it means that no VM kernel is being used?

Jun 29 2019, 12:55 PM · upstream, usability, enhancement, anon-meta-packages, Whonix
Patrick updated subscribers of T324: Add package needrestart.

needrestart works good enough for it to be implemented as a test in whonixcheck (--verbose?).

Jun 29 2019, 12:13 PM · upstream, usability, enhancement, anon-meta-packages, Whonix

Jun 27 2019

Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Jun 27 2019, 12:59 PM · anon-meta-packages, research, Whonix
Patrick edited projects for T921: Installing git-all will delete some Whonix packages , added: Whonix 16, anon-meta-packages; removed Whonix 15.
Jun 27 2019, 9:01 AM · Whonix

Jun 14 2019

Patrick edited projects for T803: coyIM, added: Whonix 16; removed Whonix 15.
Jun 14 2019, 3:30 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

May 22 2019

Patrick added a comment to T803: coyIM.

@Patrick were you able to reproduce this?

May 22 2019, 6:45 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix
HulaHoop added a comment to T803: coyIM.

@Patrick were you able to reproduce this? I wasn't

May 22 2019, 7:37 AM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix
HulaHoop added a comment to T803: coyIM.

He was a major dev/creator of CoyIM but not the only one.

May 22 2019, 7:36 AM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

Apr 23 2019

Patrick closed T485: whonix-host-qemu-kvm package has an unmet dependency. Depends: whonix-host-shared but is not installable as Invalid.

No such package anymore.

Apr 23 2019, 12:36 PM · anon-meta-packages, Whonix, Whonix-Host

Apr 19 2019

TNTBOMBOM added a comment to T803: coyIM.

also another reason why CoyIM wont come back in the near future:

Apr 19 2019, 12:29 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

Apr 17 2019

Patrick updated subscribers of T803: coyIM.
Apr 17 2019, 6:09 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix
Patrick reopened T803: coyIM as "Open".

Should remove coyim. Reason:

Apr 17 2019, 3:52 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix
Patrick added a project to T803: coyIM: anon-meta-packages.
Apr 17 2019, 3:51 PM · Debian version 11 codename Bullseye, Whonix 16, anon-meta-packages, Whonix

Apr 14 2019

Patrick closed T786: consider installing phonon4qt5-backend-null by default on Whonix-Gateway as Invalid.

Since we no longer install any KDE applications by default (such as dolphin; ark), no dependency pulls phonon anymore so in extension nothing pulls vlc anything anymore. Therefore this is no longer needed.

Apr 14 2019, 5:50 PM · Whonix, anon-meta-packages, Whonix 15
Patrick closed T595: install onionshare by default in Whonix 15 as Resolved.
Apr 14 2019, 3:36 PM · Whonix 15, Debian version 10 codename Buster, Whonix, anon-meta-packages, usability
Patrick closed T888: change Qubes-Whonix default applications from KDE-ish to XFCE-ish as Resolved.
Apr 14 2019, 3:30 PM · Whonix, Debian version 10 codename Buster, Whonix 15, anon-meta-packages, qubes-template-whonix, Qubes

Apr 6 2019

Patrick closed T890: Have cryptsetup installed by default in Whonix as Resolved.

https://github.com/Whonix/anon-meta-packages/commit/2d96e901c5be0438281ac2dc1d07aea38923b2b4

Apr 6 2019, 4:50 PM · anon-meta-packages, Whonix, Whonix 15
Patrick changed the status of T888: change Qubes-Whonix default applications from KDE-ish to XFCE-ish from Open to testing-in-next-build-required.

https://github.com/Whonix/anon-meta-packages/blob/master/debian/control

Apr 6 2019, 4:44 PM · Whonix, Debian version 10 codename Buster, Whonix 15, anon-meta-packages, qubes-template-whonix, Qubes
Patrick changed the status of T595: install onionshare by default in Whonix 15 from Open to testing-in-next-build-required.

added

Apr 6 2019, 4:36 PM · Whonix 15, Debian version 10 codename Buster, Whonix, anon-meta-packages, usability

Jan 20 2019

Patrick updated subscribers of T890: Have cryptsetup installed by default in Whonix.
Jan 20 2019, 6:06 AM · anon-meta-packages, Whonix, Whonix 15
Patrick lowered the priority of T890: Have cryptsetup installed by default in Whonix from Normal to Low.

postpone to Whonix 15 since cryptsetup has initramfs hooks (small chance of regressions)

Jan 20 2019, 6:04 AM · anon-meta-packages, Whonix, Whonix 15

Jan 19 2019

Patrick added a project to T890: Have cryptsetup installed by default in Whonix: Whonix 14.
Jan 19 2019, 8:41 AM · anon-meta-packages, Whonix, Whonix 15
Patrick added projects to T890: Have cryptsetup installed by default in Whonix: Whonix, anon-meta-packages.
Jan 19 2019, 8:40 AM · anon-meta-packages, Whonix, Whonix 15

Jan 12 2019

Patrick triaged T888: change Qubes-Whonix default applications from KDE-ish to XFCE-ish as Normal priority.
Jan 12 2019, 7:50 AM · Whonix, Debian version 10 codename Buster, Whonix 15, anon-meta-packages, qubes-template-whonix, Qubes
Patrick renamed T595: install onionshare by default in Whonix 15 from decide if we should install onionshare by default in Whonix 14 to install onionshare by default in Whonix 15.
Jan 12 2019, 7:47 AM · Whonix 15, Debian version 10 codename Buster, Whonix, anon-meta-packages, usability
Patrick edited projects for T595: install onionshare by default in Whonix 15, added: Debian version 10 codename Buster, Whonix 15; removed Debian version 9 codename Stretch, Whonix 14.
Jan 12 2019, 7:12 AM · Whonix 15, Debian version 10 codename Buster, Whonix, anon-meta-packages, usability

Jan 11 2019

HulaHoop reopened T595: install onionshare by default in Whonix 15 as "Open".

Onionshare is in Buster.
https://packages.debian.org/buster/onionshare

Jan 11 2019, 7:46 PM · Whonix 15, Debian version 10 codename Buster, Whonix, anon-meta-packages, usability

Dec 7 2018

Patrick removed a project from T324: Add package needrestart: Whonix 15.
Dec 7 2018, 11:56 AM · upstream, usability, enhancement, anon-meta-packages, Whonix

Oct 1 2018

Patrick placed T324: Add package needrestart up for grabs.
Oct 1 2018, 1:17 PM · upstream, usability, enhancement, anon-meta-packages, Whonix

Sep 11 2018

Patrick closed T457: install accessibility tools by default as Invalid.
Sep 11 2018, 7:41 PM · Whonix 15, enhancement, usability, Whonix, anon-meta-packages

Aug 8 2018

Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:58 AM · anon-meta-packages, research, Whonix
Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:39 AM · anon-meta-packages, research, Whonix
Patrick updated the task description for T215: install electrum bitcoin thin client by default?.
Aug 8 2018, 10:37 AM · anon-meta-packages, research, Whonix

Jun 30 2018

Patrick added a comment to T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade.

TODO: investigate and scrub leftovers

Jun 30 2018, 12:36 PM · whonix-legacy, Whonix

May 8 2018

Patrick placed T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade up for grabs.
May 8 2018, 9:49 PM · whonix-legacy, Whonix

Apr 6 2018

Patrick closed T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix as Resolved.
In T641#15836, @unman wrote:

Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

Apr 6 2018, 8:34 AM · Whonix 14, Whonix, anon-meta-packages, Qubes
Patrick updated the task description for T786: consider installing phonon4qt5-backend-null by default on Whonix-Gateway.
Apr 6 2018, 8:32 AM · Whonix, anon-meta-packages, Whonix 15
Patrick triaged T786: consider installing phonon4qt5-backend-null by default on Whonix-Gateway as Normal priority.
Apr 6 2018, 8:30 AM · Whonix, anon-meta-packages, Whonix 15

Apr 4 2018

unman added a comment to T641: Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.

@Patrick
Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

Apr 4 2018, 5:27 PM · Whonix 14, Whonix, anon-meta-packages, Qubes

Mar 14 2018

Patrick assigned T778: scrub environment variables leftovers from Whonix 13 -> Whonix 14 upgrade to unman.

Looks like nothing serious.

Mar 14 2018, 2:14 PM · whonix-legacy, Whonix
Patrick closed T760: compare ps aux Whonix 13 -> Whonix 14 as Resolved.

Looks like nothing unexpected / nothing need fixing.

Mar 14 2018, 2:10 PM · Whonix 14, Whonix, anon-meta-packages
Patrick closed T761: compare dpkg -l Whonix 13 -> Whonix 14 as Resolved.

Looks like nothing unexpected / nothing need fixing.

Mar 14 2018, 2:09 PM · anon-meta-packages, Whonix, Whonix 14
unman added a comment to T760: compare ps aux Whonix 13 -> Whonix 14.

I have performed a number of upgrades of GW and WS using the latest rc.
I have taken snapshots of running processes, and I would say that (almost) all of the main differences seem to be related to KDE changes between the versions.

Mar 14 2018, 1:52 AM · Whonix 14, Whonix, anon-meta-packages