Page MenuHomePhabricator

Installing git-all will delete some Whonix packages
Open, NormalPublic

Description

installing git-all package will results into damaging Whonix-ws-15:

https://privatebin.net/?3e85d10070c10735#9Q8yy+JMmmSYyelnUPtmbN4belioCLQ4PNITf2ZZ0GU=

This issue only in Whonix not in Debian template.

Command used:

sudo apt install git-all
Get:86 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libdatetime-format-iso8601-perl all 0.08-2 [15.7 kB]
    Get:87 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-mediawiki all 1:2.20.1-2 [807 kB]
    Get:88 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libserf-1-1 amd64 1.3.9-7+b10 [53.6 kB]
    Get:89 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libutf8proc2 amd64 2.3.0-1 [53.0 kB]
    Get:90 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libsvn1 amd64 1.10.4-1 [1,400 kB]
    Get:91 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libsvn-perl amd64 1.10.4-1 [1,046 kB]
    Get:92 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libyaml-perl all 1.27-1 [66.8 kB]
    Get:93 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libterm-readkey-perl amd64 2.38-1 [27.4 kB]
    Get:94 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-svn all 1:2.20.1-2 [866 kB]
    Get:95 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-email all 1:2.20.1-2 [816 kB]
    Get:96 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libtcl8.6 amd64 8.6.9+dfsg-2 [1,005 kB]
    Get:97 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libtk8.6 amd64 8.6.9-2 [768 kB]
    Get:98 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 tk8.6 amd64 8.6.9-2 [72.1 kB]
    Get:99 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 tcl8.6 amd64 8.6.9+dfsg-2 [123 kB]
    Get:100 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 tcl amd64 8.6.9+1 [5,636 B]
    Get:101 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 tk amd64 8.6.9+1 [5,676 B]
    Get:102 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-gui all 1:2.20.1-2 [1,002 kB]
    Get:103 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 gitk all 1:2.20.1-2 [922 kB]
    Get:104 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libcgi-pm-perl all 4.40-1 [222 kB]
    Get:105 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 gitweb all 1:2.20.1-2 [796 kB]
    Get:106 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-all all 1:2.20.1-2 [792 kB]
    Get:107 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 runit-helper all 2.8.6 [4,900 B]
    Get:108 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 sysuser-helper all 1.3.3 [3,844 B]
    Get:109 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 runit amd64 2.1.2-25 [112 kB]
    Get:110 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 git-daemon-run all 1:2.20.1-2 [794 kB]
    Get:111 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 guile-2.2-libs amd64 2.2.4+1-2 [4,969 kB]
    Get:112 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libauthen-sasl-perl all 2.1600-1 [50.8 kB]
    Get:113 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libfcgi-perl amd64 0.78-2+b3 [39.0 kB]
    Get:114 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libcgi-fast-perl all 1:2.13-1 [11.4 kB]
    Get:115 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libclass-c3-xs-perl amd64 0.14-1+b3 [16.9 kB]
    Get:116 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libclass-xsaccessor-perl amd64 1.19-3+b2 [38.0 kB]
    Get:117 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libcommon-sense-perl amd64 3.74-2+b7 [24.0 kB]
    Get:118 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libpadwalker-perl amd64 2.3-1+b1 [20.1 kB]
    Get:119 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libdevel-caller-perl amd64 2.06-2+b1 [12.1 kB]
    Get:120 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libdevel-lexalias-perl amd64 0.05-2+b1 [9,068 B]
    Get:121 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libdigest-bubblebabble-perl all 0.02-2 [8,238 B]
    Get:122 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libdigest-hmac-perl all 1.03+dfsg-2 [10.6 kB]
    Get:123 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libnet-ip-perl all 1.26-2 [29.0 kB]
    Get:124 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libnet-dns-perl all 1.19-1 [372 kB]
    Get:125 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libnet-domain-tld-perl all 1.75-1 [33.3 kB]
    Get:126 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libemail-valid-perl all 1.202-1 [23.0 kB]
    Get:127 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libntlm0 amd64 1.5-1 [22.0 kB]
    Get:128 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libgsasl7 amd64 1.8.0-8+b2 [207 kB]
    Get:129 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libtypes-serialiser-perl all 1.0-1 [12.7 kB]
    Get:130 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libjson-xs-perl amd64 3.040-1+b1 [91.0 kB]
    Get:131 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libkyotocabinet16v5 amd64 1.2.76-4.2+b1 [298 kB]
    Get:132 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 mailutils-common all 1:3.5-3 [689 kB]
    Get:133 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 mysql-common all 5.8+1.0.5 [7,324 B]
    Get:134 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 mariadb-common all 1:10.3.15-1 [31.3 kB]
    Get:135 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libmariadb3 amd64 1:10.3.15-1 [173 kB]
    Get:136 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libmailutils5 amd64 1:3.5-3 [881 kB]
    Get:137 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libnet-dns-sec-perl amd64 1.11-1 [48.1 kB]
    Get:138 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libnet-libidn-perl amd64 0.12.ds-3+b1 [18.6 kB]
    Get:139 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libpackage-stash-xs-perl amd64 0.29-1 [19.8 kB]
    Get:140 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libreadonly-perl all 2.050-1 [22.7 kB]
    Get:141 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libref-util-perl all 0.204-1 [17.1 kB]
    Get:142 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libref-util-xs-perl amd64 0.117-1+b1 [14.0 kB]
    Get:143 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 libyaml-libyaml-perl amd64 0.76+repack-1 [33.1 kB]
    Get:144 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 mailutils amd64 1:3.5-3 [585 kB]
    Get:145 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 runit-sysv all 2.1.2-25 [16.8 kB]
    Get:146 tor+http://vwakviie2ienjx6t.onion/debian buster/main amd64 ssl-cert all 1.0.39 [20.8 kB]
    Fetched 79.8 MB in 7min 18s (182 kB/s)                                         
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    (Reading database ... 58664 files and directories currently installed.)
    Removing qubes-whonix-workstation (3:11.7-1) ...
    Removing whonix-workstation-shared-packages-shared-meta (3:11.7-1) ...
    Removing whonix-shared-packages-recommended-cli (3:11.7-1) ...
    Removing hardened-packages-dependencies-cli (3:11.7-1) ...
    Removing bootclockrandomization (3:3.2-1) ...
    Removing whonixcheck (3:11.2-1) ...
    Removing whonix-workstation-packages-recommended-gui (3:11.7-1) ...
    Removing whonix-ws-start-menu-additions (3:2.1-1) ...
    Removing hardened-desktop-applications-xfce (3:11.7-1) ...
    Removing policykit-1-gnome (0.105-7) ...
    Removing policykit-1 (0.105-25) ...
    Removing tb-updater (3:9.1-1) ...
    Removing whonix-shared-default-applications-gui (3:11.7-1) ...
    Removing msgcollector-gui (3:4.1-1) ...
    Removing open-link-confirmation (3:3.0-1) ...
    dpkg: gvfs-daemons: dependency problems, but removing anyway as you requested:
     gvfs:amd64 depends on gvfs-daemons (<< 1.38.1-5.1~).
     gvfs:amd64 depends on gvfs-daemons (>= 1.38.1-5).
     gvfs:amd64 depends on gvfs-daemons (<< 1.38.1-5.1~).
     gvfs:amd64 depends on gvfs-daemons (>= 1.38.1-5).

    Removing gvfs-daemons (1.38.1-5) ...
    Removing udisks2 (2.8.1-4) ...
    Removing libpam-systemd:amd64 (241-5) ...
    dpkg: systemd-sysv: dependency problems, but removing anyway as you requested:
     init depends on systemd-sysv | sysvinit-core | runit-init; however:
      Package systemd-sysv is to be removed.
      Package sysvinit-core is not installed.
      Package runit-init is not installed.

    Removing systemd-sysv (241-5) ...
    dpkg: tb-starter: dependency problems, but removing anyway as you requested:
     tb-default-browser depends on tb-starter.

    Removing tb-starter (3:5.1-1) ...
    Removing msgcollector (3:4.1-1) ...
    Removing 'diversion of /etc/bash.bash_logout to /etc/bash.bash_logout.anondist-orig by msgcollector'
    Removing gvfs:amd64 (1.38.1-5) ...
    Selecting previously unselected package sysvinit-core.
    (Reading database ... 58220 files and directories currently installed.)
    Preparing to unpack .../sysvinit-core_2.93-8_amd64.deb ...
    Unpacking sysvinit-core (2.93-8) ...
    (Reading database ... 58243 files and directories currently installed.)
    Removing tb-default-browser (3:2.6-1) ...
    Selecting previously unselected package install-info.
    (Reading database ... 58232 files and directories currently installed.)
    Preparing to unpack .../install-info_6.5.0.dfsg.1-4+b1_amd64.deb ...
    Unpacking install-info (6.5.0.dfsg.1-4+b1) ...
    Setting up install-info (6.5.0.dfsg.1-4+b1) ...
    Selecting previously unselected package libapr1:amd64.
    (Reading database ... 58247 files and directories currently installed.)
    Preparing to unpack .../000-libapr1_1.6.5-1+b1_amd64.deb ...
    Unpacking libapr1:amd64 (1.6.5-1+b1) ...
    Selecting previously unselected package libaprutil1:amd64.
    Preparing to unpack .../001-libaprutil1_1.6.1-4_amd64.deb ...
    Unpacking libaprutil1:amd64 (1.6.1-4) ...
    Selecting previously unselected package libaprutil1-dbd-sqlite3:amd64.
    Preparing to unpack .../002-libaprutil1-dbd-sqlite3_1.6.1-4_amd64.deb ...
    Unpacking libaprutil1-dbd-sqlite3:amd64 (1.6.1-4) ...
    Selecting previously unselected package libaprutil1-ldap:amd64.
    Preparing to unpack .../003-libaprutil1-ldap_1.6.1-4_amd64.deb ...
    Unpacking libaprutil1-ldap:amd64 (1.6.1-4) ...
    Selecting previously unselected package apache2-bin.
    Preparing to unpack .../004-apache2-bin_2.4.38-3_amd64.deb ...
    Unpacking apache2-bin (2.4.38-3) ...
    Selecting previously unselected package apache2-data.
    Preparing to unpack .../005-apache2-data_2.4.38-3_all.deb ...
    Unpacking apache2-data (2.4.38-3) ...
    Selecting previously unselected package apache2-utils.
    Preparing to unpack .../006-apache2-utils_2.4.38-3_amd64.deb ...
    Unpacking apache2-utils (2.4.38-3) ...
    Selecting previously unselected package apache2.
    Preparing to unpack .../007-apache2_2.4.38-3_amd64.deb ...
    Unpacking apache2 (2.4.38-3) ...
    Selecting previously unselected package openssh-client.
    Preparing to unpack .../008-openssh-client_1%3a7.9p1-10_amd64.deb ...
    Unpacking openssh-client (1:7.9p1-10) ...
    Selecting previously unselected package cvs.
    Preparing to unpack .../009-cvs_2%3a1.12.13+real-27_amd64.deb ...
    Unpacking cvs (2:1.12.13+real-27) ...
    Selecting previously unselected package cvsps.
    Preparing to unpack .../010-cvsps_2.1-8_amd64.deb ...
    Unpacking cvsps (2.1-8) ...
    Selecting previously unselected package emacs-common.
    Preparing to unpack .../011-emacs-common_1%3a26.1+1-3.2_all.deb ...
    Unpacking emacs-common (1:26.1+1-3.2) ...
    Selecting previously unselected package emacs-bin-common.
    Preparing to unpack .../012-emacs-bin-common_1%3a26.1+1-3.2_amd64.deb ...
    Unpacking emacs-bin-common (1:26.1+1-3.2) ...
    Selecting previously unselected package libgif7:amd64.
    Preparing to unpack .../013-libgif7_5.1.4-3_amd64.deb ...
    Unpacking libgif7:amd64 (5.1.4-3) ...
    Selecting previously unselected package m17n-db.
    Preparing to unpack .../014-m17n-db_1.8.0-1_all.deb ...
    Unpacking m17n-db (1.8.0-1) ...
    Selecting previously unselected package libgd3:amd64.
    Preparing to unpack .../015-libgd3_2.2.5-5.2_amd64.deb ...
    Unpacking libgd3:amd64 (2.2.5-5.2) ...
    Selecting previously unselected package libotf0:amd64.
    Preparing to unpack .../016-libotf0_0.9.13-4_amd64.deb ...
    Unpacking libotf0:amd64 (0.9.13-4) ...
    Selecting previously unselected package libm17n-0:amd64.
    Preparing to unpack .../017-libm17n-0_1.8.0-2_amd64.deb ...
    Unpacking libm17n-0:amd64 (1.8.0-2) ...
    Selecting previously unselected package emacs-gtk.
    Preparing to unpack .../018-emacs-gtk_1%3a26.1+1-3.2_amd64.deb ...
    Unpacking emacs-gtk (1:26.1+1-3.2) ...
    Selecting previously unselected package emacs.
    Preparing to unpack .../019-emacs_1%3a26.1+1-3.2_all.deb ...
    Unpacking emacs (1:26.1+1-3.2) ...
    Selecting previously unselected package elpa-async.
    Preparing to unpack .../020-elpa-async_1.9.3-1_all.deb ...
    Unpacking elpa-async (1.9.3-1) ...
    Selecting previously unselected package elpa-dash.
    Preparing to unpack .../021-elpa-dash_2.14.1+dfsg-1_all.deb ...
    Unpacking elpa-dash (2.14.1+dfsg-1) ...
    Selecting previously unselected package elpa-graphql.
    Preparing to unpack .../022-elpa-graphql_0.1.1-3_all.deb ...
    Unpacking elpa-graphql (0.1.1-3) ...
    Selecting previously unselected package elpa-let-alist.
    Preparing to unpack .../023-elpa-let-alist_1.0.5-3_all.deb ...
    Unpacking elpa-let-alist (1.0.5-3) ...
    Selecting previously unselected package elpa-treepy.
    Preparing to unpack .../024-elpa-treepy_0.1.1-1_all.deb ...
    Unpacking elpa-treepy (0.1.1-1) ...
    Selecting previously unselected package elpa-ghub.
    Preparing to unpack .../025-elpa-ghub_3.2.0-1_all.deb ...
    Unpacking elpa-ghub (3.2.0-1) ...
    Selecting previously unselected package elpa-with-editor.
    Preparing to unpack .../026-elpa-with-editor_2.8.1-1_all.deb ...
    Unpacking elpa-with-editor (2.8.1-1) ...
    Selecting previously unselected package elpa-git-commit.
    Preparing to unpack .../027-elpa-git-commit_2.90.1-2_all.deb ...
    Unpacking elpa-git-commit (2.90.1-2) ...
    Selecting previously unselected package liberror-perl.
    Preparing to unpack .../028-liberror-perl_0.17027-2_all.deb ...
    Unpacking liberror-perl (0.17027-2) ...
    Selecting previously unselected package git-man.
    Preparing to unpack .../029-git-man_1%3a2.20.1-2_all.deb ...
    Unpacking git-man (1:2.20.1-2) ...
    Selecting previously unselected package git.
    Preparing to unpack .../030-git_1%3a2.20.1-2_amd64.deb ...
    Unpacking git (1:2.20.1-2) ...
    Selecting previously unselected package elpa-magit-popup.
    Preparing to unpack .../031-elpa-magit-popup_2.12.5-1_all.deb ...
    Unpacking elpa-magit-popup (2.12.5-1) ...
    Selecting previously unselected package elpa-magit.
    Preparing to unpack .../032-elpa-magit_2.90.1-2_all.deb ...
    Unpacking elpa-magit (2.90.1-2) ...
    Selecting previously unselected package emacs-el.
    Preparing to unpack .../033-emacs-el_1%3a26.1+1-3.2_all.deb ...
    Unpacking emacs-el (1:26.1+1-3.2) ...
    Selecting previously unselected package exim4-config.
    Preparing to unpack .../034-exim4-config_4.92-7_all.deb ...
    Unpacking exim4-config (4.92-7) ...
    Selecting previously unselected package exim4-base.
    Preparing to unpack .../035-exim4-base_4.92-7_amd64.deb ...
    Unpacking exim4-base (4.92-7) ...
    Selecting previously unselected package libunbound8:amd64.
    Preparing to unpack .../036-libunbound8_1.9.0-2_amd64.deb ...
    Unpacking libunbound8:amd64 (1.9.0-2) ...
    Selecting previously unselected package libgnutls-dane0:amd64.
    Preparing to unpack .../037-libgnutls-dane0_3.6.7-4_amd64.deb ...
    Unpacking libgnutls-dane0:amd64 (3.6.7-4) ...
    Selecting previously unselected package exim4-daemon-light.
    Preparing to unpack .../038-exim4-daemon-light_4.92-7_amd64.deb ...
    Unpacking exim4-daemon-light (4.92-7) ...
    Selecting previously unselected package git-doc.
    Preparing to unpack .../039-git-doc_1%3a2.20.1-2_all.deb ...
    Unpacking git-doc (1:2.20.1-2) ...
    Selecting previously unselected package git-el.
    Preparing to unpack .../040-git-el_1%3a2.20.1-2_all.deb ...
    Unpacking git-el (1:2.20.1-2) ...
    Selecting previously unselected package libdbi-perl:amd64.
    Preparing to unpack .../041-libdbi-perl_1.642-1+b1_amd64.deb ...
    Unpacking libdbi-perl:amd64 (1.642-1+b1) ...
    Selecting previously unselected package libdbd-sqlite3-perl:amd64.
    Preparing to unpack .../042-libdbd-sqlite3-perl_1.62-3_amd64.deb ...
    Unpacking libdbd-sqlite3-perl:amd64 (1.62-3) ...
    Selecting previously unselected package git-cvs.
    Preparing to unpack .../043-git-cvs_1%3a2.20.1-2_all.deb ...
    Unpacking git-cvs (1:2.20.1-2) ...
    Selecting previously unselected package libjson-perl.
    Preparing to unpack .../044-libjson-perl_4.02000-1_all.deb ...
    Unpacking libjson-perl (4.02000-1) ...
    Selecting previously unselected package libmediawiki-api-perl.
    Preparing to unpack .../045-libmediawiki-api-perl_0.41-1_all.deb ...
    Unpacking libmediawiki-api-perl (0.41-1) ...
    Selecting previously unselected package libclass-factory-util-perl.
    Preparing to unpack .../046-libclass-factory-util-perl_1.7-3_all.deb ...
    Unpacking libclass-factory-util-perl (1.7-3) ...
    Selecting previously unselected package libclass-inspector-perl.
    Preparing to unpack .../047-libclass-inspector-perl_1.32-1_all.deb ...
    Unpacking libclass-inspector-perl (1.32-1) ...
    Selecting previously unselected package libfile-sharedir-perl.
    Preparing to unpack .../048-libfile-sharedir-perl_1.116-2_all.deb ...
    Unpacking libfile-sharedir-perl (1.116-2) ...
    Selecting previously unselected package libb-hooks-op-check-perl.
    Preparing to unpack .../049-libb-hooks-op-check-perl_0.22-1+b1_amd64.deb ...
    Unpacking libb-hooks-op-check-perl (0.22-1+b1) ...
    Selecting previously unselected package libdynaloader-functions-perl.
    Preparing to unpack .../050-libdynaloader-functions-perl_0.003-1_all.deb ...
    Unpacking libdynaloader-functions-perl (0.003-1) ...
    Selecting previously unselected package libdevel-callchecker-perl.
    Preparing to unpack .../051-libdevel-callchecker-perl_0.008-1_amd64.deb ...
    Unpacking libdevel-callchecker-perl (0.008-1) ...
    Selecting previously unselected package libparams-classify-perl.
    Preparing to unpack .../052-libparams-classify-perl_0.015-1+b1_amd64.deb ...
    Unpacking libparams-classify-perl (0.015-1+b1) ...
    Selecting previously unselected package libmodule-runtime-perl.
    Preparing to unpack .../053-libmodule-runtime-perl_0.016-1_all.deb ...
    Unpacking libmodule-runtime-perl (0.016-1) ...
    Selecting previously unselected package libmodule-implementation-perl.
    Preparing to unpack .../054-libmodule-implementation-perl_0.09-1_all.deb ...
    Unpacking libmodule-implementation-perl (0.09-1) ...
    Selecting previously unselected package libsub-exporter-progressive-perl.
    Preparing to unpack .../055-libsub-exporter-progressive-perl_0.001013-1_all.deb ...
    Unpacking libsub-exporter-progressive-perl (0.001013-1) ...
    Selecting previously unselected package libvariable-magic-perl.
    Preparing to unpack .../056-libvariable-magic-perl_0.62-1+b1_amd64.deb ...
    Unpacking libvariable-magic-perl (0.62-1+b1) ...
    Selecting previously unselected package libb-hooks-endofscope-perl.
    Preparing to unpack .../057-libb-hooks-endofscope-perl_0.24-1_all.deb ...
    Unpacking libb-hooks-endofscope-perl (0.24-1) ...
    Selecting previously unselected package libpackage-stash-perl.
    Preparing to unpack .../058-libpackage-stash-perl_0.38-1_all.deb ...
    Unpacking libpackage-stash-perl (0.38-1) ...
    Selecting previously unselected package libsub-identify-perl.
    Preparing to unpack .../059-libsub-identify-perl_0.14-1+b1_amd64.deb ...
    Unpacking libsub-identify-perl (0.14-1+b1) ...
    Selecting previously unselected package libsub-name-perl.
    Preparing to unpack .../060-libsub-name-perl_0.21-1+b3_amd64.deb ...
    Unpacking libsub-name-perl (0.21-1+b3) ...
    Selecting previously unselected package libnamespace-clean-perl.
    Preparing to unpack .../061-libnamespace-clean-perl_0.27-1_all.deb ...
    Unpacking libnamespace-clean-perl (0.27-1) ...
    Selecting previously unselected package libnamespace-autoclean-perl.
    Preparing to unpack .../062-libnamespace-autoclean-perl_0.28-1_all.deb ...
    Unpacking libnamespace-autoclean-perl (0.28-1) ...
    Selecting previously unselected package libparams-util-perl.
    Preparing to unpack .../063-libparams-util-perl_1.07-3+b4_amd64.deb ...
    Unpacking libparams-util-perl (1.07-3+b4) ...
    Selecting previously unselected package libsub-install-perl.
    Preparing to unpack .../064-libsub-install-perl_0.928-1_all.deb ...
    Unpacking libsub-install-perl (0.928-1) ...
    Selecting previously unselected package libdata-optlist-perl.
    Preparing to unpack .../065-libdata-optlist-perl_0.110-1_all.deb ...
    Unpacking libdata-optlist-perl (0.110-1) ...
    Selecting previously unselected package libsub-exporter-perl.
    Preparing to unpack .../066-libsub-exporter-perl_0.987-1_all.deb ...
    Unpacking libsub-exporter-perl (0.987-1) ...
    Selecting previously unselected package libeval-closure-perl.
    Preparing to unpack .../067-libeval-closure-perl_0.14-1_all.deb ...
    Unpacking libeval-closure-perl (0.14-1) ...
    Selecting previously unselected package libclass-data-inheritable-perl.
    Preparing to unpack .../068-libclass-data-inheritable-perl_0.08-3_all.deb ...
    Unpacking libclass-data-inheritable-perl (0.08-3) ...
    Selecting previously unselected package libdevel-stacktrace-perl.
    Preparing to unpack .../069-libdevel-stacktrace-perl_2.0300-1_all.deb ...
    Unpacking libdevel-stacktrace-perl (2.0300-1) ...
    Selecting previously unselected package libexception-class-perl.
    Preparing to unpack .../070-libexception-class-perl_1.44-1_all.deb ...
    Unpacking libexception-class-perl (1.44-1) ...
    Selecting previously unselected package libparams-validationcompiler-perl.
    Preparing to unpack .../071-libparams-validationcompiler-perl_0.30-1_all.deb ...
    Unpacking libparams-validationcompiler-perl (0.30-1) ...
    Selecting previously unselected package libalgorithm-c3-perl.
    Preparing to unpack .../072-libalgorithm-c3-perl_0.10-1_all.deb ...
    Unpacking libalgorithm-c3-perl (0.10-1) ...
    Selecting previously unselected package libclass-c3-perl.
    Preparing to unpack .../073-libclass-c3-perl_0.34-1_all.deb ...
    Unpacking libclass-c3-perl (0.34-1) ...
    Selecting previously unselected package libmro-compat-perl.
    Preparing to unpack .../074-libmro-compat-perl_0.13-1_all.deb ...
    Unpacking libmro-compat-perl (0.13-1) ...
    Selecting previously unselected package libclass-method-modifiers-perl.
    Preparing to unpack .../075-libclass-method-modifiers-perl_2.12-1_all.deb ...
    Unpacking libclass-method-modifiers-perl (2.12-1) ...
    Selecting previously unselected package librole-tiny-perl.
    Preparing to unpack .../076-librole-tiny-perl_2.000006-1_all.deb ...
    Unpacking librole-tiny-perl (2.000006-1) ...
    Selecting previously unselected package libsub-quote-perl.
    Preparing to unpack .../077-libsub-quote-perl_2.005001-1_all.deb ...
    Unpacking libsub-quote-perl (2.005001-1) ...
    Selecting previously unselected package libspecio-perl.
    Preparing to unpack .../078-libspecio-perl_0.43-1_all.deb ...
    Unpacking libspecio-perl (0.43-1) ...
    Selecting previously unselected package libdatetime-locale-perl.
    Preparing to unpack .../079-libdatetime-locale-perl_1%3a1.23-1_all.deb ...
    Unpacking libdatetime-locale-perl (1:1.23-1) ...
    Selecting previously unselected package libclass-singleton-perl.
    Preparing to unpack .../080-libclass-singleton-perl_1.5-1_all.deb ...
    Unpacking libclass-singleton-perl (1.5-1) ...
    Selecting previously unselected package libdatetime-timezone-perl.
    Preparing to unpack .../081-libdatetime-timezone-perl_1%3a2.23-1+2019a_all.deb ...
    Unpacking libdatetime-timezone-perl (1:2.23-1+2019a) ...
    Selecting previously unselected package libdatetime-perl:amd64.
    Preparing to unpack .../082-libdatetime-perl_2%3a1.50-1+b1_amd64.deb ...
    Unpacking libdatetime-perl:amd64 (2:1.50-1+b1) ...
    Selecting previously unselected package libdatetime-format-strptime-perl.
    Preparing to unpack .../083-libdatetime-format-strptime-perl_1.7600-1_all.deb ...
    Unpacking libdatetime-format-strptime-perl (1.7600-1) ...
    Selecting previously unselected package libparams-validate-perl.
    Preparing to unpack .../084-libparams-validate-perl_1.29-1+b1_amd64.deb ...
    Unpacking libparams-validate-perl (1.29-1+b1) ...
    Selecting previously unselected package libdatetime-format-builder-perl.
    Preparing to unpack .../085-libdatetime-format-builder-perl_0.8100-2_all.deb ...
    Unpacking libdatetime-format-builder-perl (0.8100-2) ...
    Selecting previously unselected package libdatetime-format-iso8601-perl.
    Preparing to unpack .../086-libdatetime-format-iso8601-perl_0.08-2_all.deb ...
    Unpacking libdatetime-format-iso8601-perl (0.08-2) ...
    Selecting previously unselected package git-mediawiki.
    Preparing to unpack .../087-git-mediawiki_1%3a2.20.1-2_all.deb ...
    Unpacking git-mediawiki (1:2.20.1-2) ...
    Selecting previously unselected package libserf-1-1:amd64.
    Preparing to unpack .../088-libserf-1-1_1.3.9-7+b10_amd64.deb ...
    Unpacking libserf-1-1:amd64 (1.3.9-7+b10) ...
    Selecting previously unselected package libutf8proc2:amd64.
    Preparing to unpack .../089-libutf8proc2_2.3.0-1_amd64.deb ...
    Unpacking libutf8proc2:amd64 (2.3.0-1) ...
    Selecting previously unselected package libsvn1:amd64.
    Preparing to unpack .../090-libsvn1_1.10.4-1_amd64.deb ...
    Unpacking libsvn1:amd64 (1.10.4-1) ...
    Selecting previously unselected package libsvn-perl:amd64.
    Preparing to unpack .../091-libsvn-perl_1.10.4-1_amd64.deb ...
    Unpacking libsvn-perl:amd64 (1.10.4-1) ...
    Selecting previously unselected package libyaml-perl.
    Preparing to unpack .../092-libyaml-perl_1.27-1_all.deb ...
    Unpacking libyaml-perl (1.27-1) ...
    Selecting previously unselected package libterm-readkey-perl.
    Preparing to unpack .../093-libterm-readkey-perl_2.38-1_amd64.deb ...
    Unpacking libterm-readkey-perl (2.38-1) ...
    Selecting previously unselected package git-svn.
    Preparing to unpack .../094-git-svn_1%3a2.20.1-2_all.deb ...
    Unpacking git-svn (1:2.20.1-2) ...
    Selecting previously unselected package git-email.
    Preparing to unpack .../095-git-email_1%3a2.20.1-2_all.deb ...
    Unpacking git-email (1:2.20.1-2) ...
    Selecting previously unselected package libtcl8.6:amd64.
    Preparing to unpack .../096-libtcl8.6_8.6.9+dfsg-2_amd64.deb ...
    Unpacking libtcl8.6:amd64 (8.6.9+dfsg-2) ...
    Selecting previously unselected package libtk8.6:amd64.
    Preparing to unpack .../097-libtk8.6_8.6.9-2_amd64.deb ...
    Unpacking libtk8.6:amd64 (8.6.9-2) ...
    Selecting previously unselected package tk8.6.
    Preparing to unpack .../098-tk8.6_8.6.9-2_amd64.deb ...
    Unpacking tk8.6 (8.6.9-2) ...
    Selecting previously unselected package tcl8.6.
    Preparing to unpack .../099-tcl8.6_8.6.9+dfsg-2_amd64.deb ...
    Unpacking tcl8.6 (8.6.9+dfsg-2) ...
    Selecting previously unselected package tcl.
    Preparing to unpack .../100-tcl_8.6.9+1_amd64.deb ...
    Unpacking tcl (8.6.9+1) ...
    Selecting previously unselected package tk.
    Preparing to unpack .../101-tk_8.6.9+1_amd64.deb ...
    Unpacking tk (8.6.9+1) ...
    Selecting previously unselected package git-gui.
    Preparing to unpack .../102-git-gui_1%3a2.20.1-2_all.deb ...
    Unpacking git-gui (1:2.20.1-2) ...
    Selecting previously unselected package gitk.
    Preparing to unpack .../103-gitk_1%3a2.20.1-2_all.deb ...
    Unpacking gitk (1:2.20.1-2) ...
    Selecting previously unselected package libcgi-pm-perl.
    Preparing to unpack .../104-libcgi-pm-perl_4.40-1_all.deb ...
    Unpacking libcgi-pm-perl (4.40-1) ...
    Selecting previously unselected package gitweb.
    Preparing to unpack .../105-gitweb_1%3a2.20.1-2_all.deb ...
    Unpacking gitweb (1:2.20.1-2) ...
    Selecting previously unselected package git-all.
    Preparing to unpack .../106-git-all_1%3a2.20.1-2_all.deb ...
    Unpacking git-all (1:2.20.1-2) ...
    Selecting previously unselected package runit-helper.
    Preparing to unpack .../107-runit-helper_2.8.6_all.deb ...
    Unpacking runit-helper (2.8.6) ...
    Selecting previously unselected package sysuser-helper.
    Preparing to unpack .../108-sysuser-helper_1.3.3_all.deb ...
    Unpacking sysuser-helper (1.3.3) ...
    Selecting previously unselected package runit.
    Preparing to unpack .../109-runit_2.1.2-25_amd64.deb ...
    Unpacking runit (2.1.2-25) ...
    Selecting previously unselected package git-daemon-run.
    Preparing to unpack .../110-git-daemon-run_1%3a2.20.1-2_all.deb ...
    Unpacking git-daemon-run (1:2.20.1-2) ...
    Selecting previously unselected package guile-2.2-libs:amd64.
    Preparing to unpack .../111-guile-2.2-libs_2.2.4+1-2_amd64.deb ...
    Unpacking guile-2.2-libs:amd64 (2.2.4+1-2) ...
    Selecting previously unselected package libauthen-sasl-perl.
    Preparing to unpack .../112-libauthen-sasl-perl_2.1600-1_all.deb ...
    Unpacking libauthen-sasl-perl (2.1600-1) ...
    Selecting previously unselected package libfcgi-perl.
    Preparing to unpack .../113-libfcgi-perl_0.78-2+b3_amd64.deb ...
    Unpacking libfcgi-perl (0.78-2+b3) ...
    Selecting previously unselected package libcgi-fast-perl.
    Preparing to unpack .../114-libcgi-fast-perl_1%3a2.13-1_all.deb ...
    Unpacking libcgi-fast-perl (1:2.13-1) ...
    Selecting previously unselected package libclass-c3-xs-perl.
    Preparing to unpack .../115-libclass-c3-xs-perl_0.14-1+b3_amd64.deb ...
    Unpacking libclass-c3-xs-perl (0.14-1+b3) ...
    Selecting previously unselected package libclass-xsaccessor-perl.
    Preparing to unpack .../116-libclass-xsaccessor-perl_1.19-3+b2_amd64.deb ...
    Unpacking libclass-xsaccessor-perl (1.19-3+b2) ...
    Selecting previously unselected package libcommon-sense-perl.
    Preparing to unpack .../117-libcommon-sense-perl_3.74-2+b7_amd64.deb ...
    Unpacking libcommon-sense-perl (3.74-2+b7) ...
    Selecting previously unselected package libpadwalker-perl.
    Preparing to unpack .../118-libpadwalker-perl_2.3-1+b1_amd64.deb ...
    Unpacking libpadwalker-perl (2.3-1+b1) ...
    Selecting previously unselected package libdevel-caller-perl.
    Preparing to unpack .../119-libdevel-caller-perl_2.06-2+b1_amd64.deb ...
    Unpacking libdevel-caller-perl (2.06-2+b1) ...
    Selecting previously unselected package libdevel-lexalias-perl.
    Preparing to unpack .../120-libdevel-lexalias-perl_0.05-2+b1_amd64.deb ...
    Unpacking libdevel-lexalias-perl (0.05-2+b1) ...
    Selecting previously unselected package libdigest-bubblebabble-perl.
    Preparing to unpack .../121-libdigest-bubblebabble-perl_0.02-2_all.deb ...
    Unpacking libdigest-bubblebabble-perl (0.02-2) ...
    Selecting previously unselected package libdigest-hmac-perl.
    Preparing to unpack .../122-libdigest-hmac-perl_1.03+dfsg-2_all.deb ...
    Unpacking libdigest-hmac-perl (1.03+dfsg-2) ...
    Selecting previously unselected package libnet-ip-perl.
    Preparing to unpack .../123-libnet-ip-perl_1.26-2_all.deb ...
    Unpacking libnet-ip-perl (1.26-2) ...
    Selecting previously unselected package libnet-dns-perl.
    Preparing to unpack .../124-libnet-dns-perl_1.19-1_all.deb ...
    Unpacking libnet-dns-perl (1.19-1) ...
    Selecting previously unselected package libnet-domain-tld-perl.
    Preparing to unpack .../125-libnet-domain-tld-perl_1.75-1_all.deb ...
    Unpacking libnet-domain-tld-perl (1.75-1) ...
    Selecting previously unselected package libemail-valid-perl.
    Preparing to unpack .../126-libemail-valid-perl_1.202-1_all.deb ...
    Unpacking libemail-valid-perl (1.202-1) ...
    Selecting previously unselected package libntlm0:amd64.
    Preparing to unpack .../127-libntlm0_1.5-1_amd64.deb ...
    Unpacking libntlm0:amd64 (1.5-1) ...
    Selecting previously unselected package libgsasl7.
    Preparing to unpack .../128-libgsasl7_1.8.0-8+b2_amd64.deb ...
    Unpacking libgsasl7 (1.8.0-8+b2) ...
    Selecting previously unselected package libtypes-serialiser-perl.
    Preparing to unpack .../129-libtypes-serialiser-perl_1.0-1_all.deb ...
    Unpacking libtypes-serialiser-perl (1.0-1) ...
    Selecting previously unselected package libjson-xs-perl.
    Preparing to unpack .../130-libjson-xs-perl_3.040-1+b1_amd64.deb ...
    Unpacking libjson-xs-perl (3.040-1+b1) ...
    Selecting previously unselected package libkyotocabinet16v5:amd64.
    Preparing to unpack .../131-libkyotocabinet16v5_1.2.76-4.2+b1_amd64.deb ...
    Unpacking libkyotocabinet16v5:amd64 (1.2.76-4.2+b1) ...
    Selecting previously unselected package mailutils-common.
    Preparing to unpack .../132-mailutils-common_1%3a3.5-3_all.deb ...
    Unpacking mailutils-common (1:3.5-3) ...
    Selecting previously unselected package mysql-common.
    Preparing to unpack .../133-mysql-common_5.8+1.0.5_all.deb ...
    Unpacking mysql-common (5.8+1.0.5) ...
    Selecting previously unselected package mariadb-common.
    Preparing to unpack .../134-mariadb-common_1%3a10.3.15-1_all.deb ...
    Unpacking mariadb-common (1:10.3.15-1) ...
    Selecting previously unselected package libmariadb3:amd64.
    Preparing to unpack .../135-libmariadb3_1%3a10.3.15-1_amd64.deb ...
    Unpacking libmariadb3:amd64 (1:10.3.15-1) ...
    Selecting previously unselected package libmailutils5:amd64.
    Preparing to unpack .../136-libmailutils5_1%3a3.5-3_amd64.deb ...
    Unpacking libmailutils5:amd64 (1:3.5-3) ...
    Selecting previously unselected package libnet-dns-sec-perl.
    Preparing to unpack .../137-libnet-dns-sec-perl_1.11-1_amd64.deb ...
    Unpacking libnet-dns-sec-perl (1.11-1) ...
    Selecting previously unselected package libnet-libidn-perl.
    Preparing to unpack .../138-libnet-libidn-perl_0.12.ds-3+b1_amd64.deb ...
    Unpacking libnet-libidn-perl (0.12.ds-3+b1) ...
    Selecting previously unselected package libpackage-stash-xs-perl.
    Preparing to unpack .../139-libpackage-stash-xs-perl_0.29-1_amd64.deb ...
    Unpacking libpackage-stash-xs-perl (0.29-1) ...
    Selecting previously unselected package libreadonly-perl.
    Preparing to unpack .../140-libreadonly-perl_2.050-1_all.deb ...
    Unpacking libreadonly-perl (2.050-1) ...
    Selecting previously unselected package libref-util-perl.
    Preparing to unpack .../141-libref-util-perl_0.204-1_all.deb ...
    Unpacking libref-util-perl (0.204-1) ...
    Selecting previously unselected package libref-util-xs-perl.
    Preparing to unpack .../142-libref-util-xs-perl_0.117-1+b1_amd64.deb ...
    Unpacking libref-util-xs-perl (0.117-1+b1) ...
    Selecting previously unselected package libyaml-libyaml-perl.
    Preparing to unpack .../143-libyaml-libyaml-perl_0.76+repack-1_amd64.deb ...
    Unpacking libyaml-libyaml-perl (0.76+repack-1) ...
    Selecting previously unselected package mailutils.
    Preparing to unpack .../144-mailutils_1%3a3.5-3_amd64.deb ...
    Unpacking mailutils (1:3.5-3) ...
    Selecting previously unselected package runit-sysv.
    Preparing to unpack .../145-runit-sysv_2.1.2-25_all.deb ...
    Unpacking runit-sysv (2.1.2-25) ...
    Selecting previously unselected package ssl-cert.
    Preparing to unpack .../146-ssl-cert_1.0.39_all.deb ...
    Unpacking ssl-cert (1.0.39) ...
    Setting up runit-helper (2.8.6) ...
    Setting up mysql-common (5.8+1.0.5) ...
    update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
    Setting up libotf0:amd64 (0.9.13-4) ...
    Setting up elpa-graphql (0.1.1-3) ...
    Setting up libclass-inspector-perl (1.32-1) ...
    Setting up libdynaloader-functions-perl (0.003-1) ...
    Setting up libclass-method-modifiers-perl (2.12-1) ...
    Setting up libref-util-xs-perl (0.117-1+b1) ...
    Setting up libsub-identify-perl (0.14-1+b1) ...
    Setting up openssh-client (1:7.9p1-10) ...
    Setting up cvs (2:1.12.13+real-27) ...
    Allowing use of questionable username.
    Adding group `_cvsadmin' (GID 123) ...
    Done.
    Setting up libauthen-sasl-perl (2.1600-1) ...
    Setting up libutf8proc2:amd64 (2.3.0-1) ...
    Setting up libkyotocabinet16v5:amd64 (1.2.76-4.2+b1) ...
    Setting up libcgi-pm-perl (4.40-1) ...
    Setting up libyaml-libyaml-perl (0.76+repack-1) ...
    Setting up libapr1:amd64 (1.6.5-1+b1) ...
    Setting up m17n-db (1.8.0-1) ...
    Setting up libcommon-sense-perl (3.74-2+b7) ...
    Setting up libclass-singleton-perl (1.5-1) ...
    Setting up libpadwalker-perl (2.3-1+b1) ...
    Setting up elpa-with-editor (2.8.1-1) ...
    Setting up git-doc (1:2.20.1-2) ...
    Setting up libyaml-perl (1.27-1) ...
    Setting up libclass-c3-xs-perl (0.14-1+b3) ...
    Setting up libdevel-caller-perl (2.06-2+b1) ...
    Setting up libsub-install-perl (0.928-1) ...
    Setting up liberror-perl (0.17027-2) ...
    Setting up mariadb-common (1:10.3.15-1) ...
    update-alternatives: using /etc/mysql/mariadb.cnf to provide /etc/mysql/my.cnf (my.cnf) in auto mode
    Setting up libreadonly-perl (2.050-1) ...
    Setting up libdevel-lexalias-perl (0.05-2+b1) ...
    Setting up libpackage-stash-xs-perl (0.29-1) ...
    Setting up elpa-treepy (0.1.1-1) ...
    Setting up libclass-data-inheritable-perl (0.08-3) ...
    Setting up libunbound8:amd64 (1.9.0-2) ...
    Setting up elpa-dash (2.14.1+dfsg-1) ...
    Setting up libalgorithm-c3-perl (0.10-1) ...
    Setting up libdigest-hmac-perl (1.03+dfsg-2) ...
    Setting up libntlm0:amd64 (1.5-1) ...
    Setting up libref-util-perl (0.204-1) ...
    Setting up ssl-cert (1.0.39) ...
    hostname: Non-recoverable failure in name resolution
    make-ssl-cert: Could not get FQDN, using "host".
    make-ssl-cert: You may want to fix your /etc/hosts and/or DNS setup and run
    make-ssl-cert: make-ssl-cert generate-default-snakeoil --force-overwrite
    make-ssl-cert: again.
    Setting up libnet-domain-tld-perl (1.75-1) ...
    Setting up libnet-libidn-perl (0.12.ds-3+b1) ...
    Setting up libgd3:amd64 (2.2.5-5.2) ...
    Setting up libvariable-magic-perl (0.62-1+b1) ...
    Setting up mailutils-common (1:3.5-3) ...
    Setting up libtcl8.6:amd64 (8.6.9+dfsg-2) ...
    Setting up libb-hooks-op-check-perl (0.22-1+b1) ...
    Setting up libmariadb3:amd64 (1:10.3.15-1) ...
    Setting up libparams-util-perl (1.07-3+b4) ...
    Setting up libsub-exporter-progressive-perl (0.001013-1) ...
    Setting up sysuser-helper (1.3.3) ...
    Setting up libsub-name-perl (0.21-1+b3) ...
    Setting up libgif7:amd64 (5.1.4-3) ...
    Setting up libtypes-serialiser-perl (1.0-1) ...
    Setting up elpa-let-alist (1.0.5-3) ...
    Setting up exim4-config (4.92-7) ...
    Adding system-user for exim (v4)
    /usr/sbin/update-exim4.conf: 467: /usr/sbin/update-exim4.conf: /usr/sbin/exim4: Operation not permitted
    Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing 
    /var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.autogenerated
    dpkg: error processing package exim4-config (--configure):
     installed exim4-config package post-installation script subprocess returned error exit status 1
    Setting up libclass-factory-util-perl (1.7-3) ...
    Setting up libjson-perl (4.02000-1) ...
    Setting up librole-tiny-perl (2.000006-1) ...
    Setting up libfile-sharedir-perl (1.116-2) ...
    Setting up libfcgi-perl (0.78-2+b3) ...
    Setting up git-man (1:2.20.1-2) ...
    Setting up libsub-quote-perl (2.005001-1) ...
    Setting up libdevel-stacktrace-perl (2.0300-1) ...
    Setting up libclass-xsaccessor-perl (1.19-3+b2) ...
    Setting up apache2-data (2.4.38-3) ...
    Setting up cvsps (2.1-8) ...
    Setting up libterm-readkey-perl (2.38-1) ...
    Setting up emacs-common (1:26.1+1-3.2) ...
    Setting up libnet-ip-perl (1.26-2) ...
    Setting up sysvinit-core (2.93-8) ...
    Not restarting sysvinit
    Setting up elpa-git-commit (2.90.1-2) ...
    tsort: -: input contains a loop:
    tsort: elpa-dash
    tsort: emacsen-common
    tsort: -: input contains a loop:
    tsort: emacsen-common
    tsort: elpa-with-editor
    Setting up guile-2.2-libs:amd64 (2.2.4+1-2) ...
    Setting up libdbi-perl:amd64 (1.642-1+b1) ...
    Setting up libaprutil1:amd64 (1.6.1-4) ...
    Setting up libdigest-bubblebabble-perl (0.02-2) ...
    Setting up elpa-ghub (3.2.0-1) ...
    Setting up libjson-xs-perl (3.040-1+b1) ...
    Setting up libgnutls-dane0:amd64 (3.6.7-4) ...
    Setting up tcl8.6 (8.6.9+dfsg-2) ...
    dpkg: dependency problems prevent configuration of exim4-base:
     exim4-base depends on exim4-config (>= 4.82) | exim4-config-2; however:
      Package exim4-config is not configured yet.
      Package exim4-config-2 is not installed.
      Package exim4-config which provides exim4-config-2 is not configured yet.

    dpkg: error processing package exim4-base (--configure):
     dependency problems - leaving unconfigured
    Setting up libmediawiki-api-perl (0.41-1) ...
    Setting up libcgi-fast-perl (1:2.13-1) ...
    Setting up libtk8.6:amd64 (8.6.9-2) ...
    Setting up libserf-1-1:amd64 (1.3.9-7+b10) ...
    Setting up libgsasl7 (1.8.0-8+b2) ...
    Setting up libnet-dns-perl (1.19-1) ...
    Setting up libexception-class-perl (1.44-1) ...
    Setting up libm17n-0:amd64 (1.8.0-2) ...
    Setting up libaprutil1-ldap:amd64 (1.6.1-4) ...
    Setting up libclass-c3-perl (0.34-1) ...
    Setting up libaprutil1-dbd-sqlite3:amd64 (1.6.1-4) ...
    Setting up libdevel-callchecker-perl (0.008-1) ...
    Setting up runit (2.1.2-25) ...
    Setting up libdata-optlist-perl (0.110-1) ...
    Setting up emacs-el (1:26.1+1-3.2) ...
    Setting up git (1:2.20.1-2) ...
    Setting up git-email (1:2.20.1-2) ...
    Setting up gitweb (1:2.20.1-2) ...
    Package apache2 is not configured yet. Will defer actions by package gitweb.
    Setting up emacs-bin-common (1:26.1+1-3.2) ...
    update-alternatives: using /usr/bin/ctags.emacs to provide /usr/bin/ctags (ctags) in auto mode
    update-alternatives: using /usr/bin/ebrowse.emacs to provide /usr/bin/ebrowse (ebrowse) in auto mode
    update-alternatives: using /usr/bin/emacsclient.emacs to provide /usr/bin/emacsclient (emacsclient) in auto mode
    update-alternatives: using /usr/bin/etags.emacs to provide /usr/bin/etags (etags) in auto mode
    Setting up libdbd-sqlite3-perl:amd64 (1.62-3) ...
    Setting up libmro-compat-perl (0.13-1) ...
    Setting up libsvn1:amd64 (1.10.4-1) ...
    Setting up runit-sysv (2.1.2-25) ...
    dpkg: dependency problems prevent configuration of exim4-daemon-light:
     exim4-daemon-light depends on exim4-base (>= 4.92); however:
      Package exim4-base is not configured yet.

    dpkg: error processing package exim4-daemon-light (--configure):
     dependency problems - leaving unconfigured
    Setting up libmailutils5:amd64 (1:3.5-3) ...
    Setting up libsub-exporter-perl (0.987-1) ...
    Setting up apache2-utils (2.4.38-3) ...
    Setting up libeval-closure-perl (0.14-1) ...
    Setting up tk8.6 (8.6.9-2) ...
    Setting up libparams-validationcompiler-perl (0.30-1) ...
    Setting up libsvn-perl:amd64 (1.10.4-1) ...
    Setting up mailutils (1:3.5-3) ...
    update-alternatives: using /usr/bin/frm.mailutils to provide /usr/bin/frm (frm) in auto mode
    update-alternatives: using /usr/bin/from.mailutils to provide /usr/bin/from (from) in auto mode
    update-alternatives: using /usr/bin/messages.mailutils to provide /usr/bin/messages (messages) in auto mode
    update-alternatives: using /usr/bin/movemail.mailutils to provide /usr/bin/movemail (movemail) in auto mode
    update-alternatives: using /usr/bin/readmsg.mailutils to provide /usr/bin/readmsg (readmsg) in auto mode
    update-alternatives: using /usr/bin/dotlock.mailutils to provide /usr/bin/dotlock (dotlock) in auto mode
    update-alternatives: using /usr/bin/mail.mailutils to provide /usr/bin/mailx (mailx) in auto mode
    Setting up git-cvs (1:2.20.1-2) ...
    Setting up git-daemon-run (1:2.20.1-2) ...
    Warning: The home dir /nonexistent you specified can't be accessed: No such file or directory
    Adding system user `gitlog' (UID 116) ...
    Adding new user `gitlog' (UID 116) with group `nogroup' ...
    Not creating home directory `/nonexistent'.
    Warning: The home dir /nonexistent you specified can't be accessed: No such file or directory
    Adding system user `gitdaemon' (UID 117) ...
    Adding new user `gitdaemon' (UID 117) with group `nogroup' ...
    Not creating home directory `/nonexistent'.
    Service git-daemon added.
    Setting up libemail-valid-perl (1.202-1) ...
    Setting up libparams-classify-perl (0.015-1+b1) ...
    Setting up libnet-dns-sec-perl (1.11-1) ...
    Setting up git-svn (1:2.20.1-2) ...
    Setting up apache2-bin (2.4.38-3) ...
    Setting up libmodule-runtime-perl (0.016-1) ...
    Setting up emacs-gtk (1:26.1+1-3.2) ...
    update-alternatives: using /usr/bin/emacs-gtk to provide /usr/bin/emacs (emacs) in auto mode
    Install emacsen-common for emacs
    emacsen-common: Handling install of emacsen flavor emacs
    Install git for emacs
    Install elpa-graphql for emacs
    install/graphql-0.1.1: Handling install of emacsen flavor emacs
    install/graphql-0.1.1: byte-compiling for emacs
    Install dictionaries-common for emacs
    install/dictionaries-common: Byte-compiling for emacsen flavour emacs
    Install elpa-treepy for emacs
    install/treepy-0.1.1: Handling install of emacsen flavor emacs
    install/treepy-0.1.1: byte-compiling for emacs
    Install elpa-dash for emacs
    install/dash-2.14.1: Handling install of emacsen flavor emacs
    install/dash-2.14.1: byte-compiling for emacs
    Install elpa-let-alist for emacs
    install/let-alist-1.0.5: Handling install of emacsen flavor emacs
    install/let-alist-1.0.5: byte-compiling for emacs
    Install elpa-with-editor for emacs
    install/with-editor-2.6.0: Handling install of emacsen flavor emacs
    install/with-editor-2.6.0: byte-compiling for emacs
    Install elpa-ghub for emacs
    install/ghub-3.0.0: Handling install of emacsen flavor emacs
    install/ghub-3.0.0: byte-compiling for emacs
    Install elpa-git-commit for emacs
    install/git-commit-2.90.1: Handling install of emacsen flavor emacs
    install/git-commit-2.90.1: byte-compiling for emacs
    Setting up git-el (1:2.20.1-2) ...
    Install git for emacs
    Install git for emacs
    Setting up emacs (1:26.1+1-3.2) ...
    Setting up libmodule-implementation-perl (0.09-1) ...
    Setting up libpackage-stash-perl (0.38-1) ...
    Setting up apache2 (2.4.38-3) ...
    Enabling module mpm_event.
    Enabling module authz_core.
    Enabling module authz_host.
    Enabling module authn_core.
    Enabling module auth_basic.
    Enabling module access_compat.
    Enabling module authn_file.
    Enabling module authz_user.
    Enabling module alias.
    Enabling module dir.
    Enabling module autoindex.
    Enabling module env.
    Enabling module mime.
    Enabling module negotiation.
    Enabling module setenvif.
    Enabling module filter.
    Enabling module deflate.
    Enabling module status.
    Enabling module reqtimeout.
    Enabling conf charset.
    Enabling conf localized-error-pages.
    Enabling conf other-vhosts-access-log.
    Enabling conf security.
    Enabling conf serve-cgi-bin.
    Enabling site 000-default.
    info: Executing deferred 'a2enconf gitweb' for package gitweb
    Enabling conf gitweb.
    Created symlink /etc/systemd/system/multi-user.target.wants/apache2.service → /lib/systemd/system/apache2.service.
    Created symlink /etc/systemd/system/multi-user.target.wants/apache-htcacheclean.service → /lib/systemd/system/apache-htcacheclean.service.
    insserv: warning: current start runlevel(s) (empty) of script `apache-htcacheclean' overrides LSB defaults (2 3 4 5).
    insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `apache-htcacheclean' overrides LSB defaults (0 1 6).
    Setting up elpa-async (1.9.3-1) ...
    Install emacsen-common for emacs
    emacsen-common: Handling install of emacsen flavor emacs
    Install elpa-async for emacs
    install/async-1.9.3: Handling install of emacsen flavor emacs
    install/async-1.9.3: byte-compiling for emacs
    Setting up elpa-magit-popup (2.12.5-1) ...
    tsort: -: input contains a loop:
    tsort: elpa-async
    tsort: emacsen-common
    tsort: -: input contains a loop:
    tsort: elpa-dash
    tsort: emacsen-common
    Install elpa-async for emacs
    install/async-1.9.3: Handling install of emacsen flavor emacs
    install/async-1.9.3: byte-compiling for emacs
    Install elpa-dash for emacs
    install/dash-2.14.1: Handling install of emacsen flavor emacs
    install/dash-2.14.1: byte-compiling for emacs
    Install emacsen-common for emacs
    emacsen-common: Handling install of emacsen flavor emacs
    Install elpa-magit-popup for emacs
    install/magit-popup-2.12.5: Handling install of emacsen flavor emacs
    install/magit-popup-2.12.5: byte-compiling for emacs
    Setting up elpa-magit (2.90.1-2) ...
    tsort: -: input contains a loop:
    tsort: elpa-dash
    tsort: emacsen-common
    tsort: -: input contains a loop:
    tsort: elpa-ghub
    tsort: emacsen-common
    tsort: -: input contains a loop:
    tsort: elpa-git-commit
    tsort: emacsen-common
    tsort: elpa-with-editor
    tsort: -: input contains a loop:
    tsort: elpa-git-commit
    tsort: emacsen-common
    tsort: -: input contains a loop:
    tsort: emacsen-common
    tsort: elpa-magit-popup
    tsort: -: input contains a loop:
    tsort: elpa-with-editor
    tsort: emacsen-common
    Install elpa-async for emacs
    install/async-1.9.3: Handling install of emacsen flavor emacs
    install/async-1.9.3: byte-compiling for emacs
    Install elpa-graphql for emacs
    install/graphql-0.1.1: Handling install of emacsen flavor emacs
    install/graphql-0.1.1: byte-compiling for emacs
    Install elpa-let-alist for emacs
    install/let-alist-1.0.5: Handling install of emacsen flavor emacs
    install/let-alist-1.0.5: byte-compiling for emacs
    Install elpa-treepy for emacs
    install/treepy-0.1.1: Handling install of emacsen flavor emacs
    install/treepy-0.1.1: byte-compiling for emacs
    Install git for emacs
    Install git for emacs
    Install elpa-dash for emacs
    install/dash-2.14.1: Handling install of emacsen flavor emacs
    install/dash-2.14.1: byte-compiling for emacs
    Install elpa-ghub for emacs
    install/ghub-3.0.0: Handling install of emacsen flavor emacs
    install/ghub-3.0.0: byte-compiling for emacs
    Install elpa-git-commit for emacs
    install/git-commit-2.90.1: Handling install of emacsen flavor emacs
    install/git-commit-2.90.1: byte-compiling for emacs
    Install elpa-with-editor for emacs
    install/with-editor-2.6.0: Handling install of emacsen flavor emacs
    install/with-editor-2.6.0: byte-compiling for emacs
    Install emacsen-common for emacs
    emacsen-common: Handling install of emacsen flavor emacs
    Install elpa-magit-popup for emacs
    install/magit-popup-2.12.5: Handling install of emacsen flavor emacs
    install/magit-popup-2.12.5: byte-compiling for emacs
    Install elpa-magit for emacs
    install/magit-2.90.1: Handling install of emacsen flavor emacs
    install/magit-2.90.1: byte-compiling for emacs
    Setting up libspecio-perl (0.43-1) ...
    Setting up libparams-validate-perl (1.29-1+b1) ...
    Setting up libb-hooks-endofscope-perl (0.24-1) ...
    Setting up libnamespace-clean-perl (0.27-1) ...
    Setting up libnamespace-autoclean-perl (0.28-1) ...
    Setting up libdatetime-locale-perl (1:1.23-1) ...
    Setting up libdatetime-timezone-perl (1:2.23-1+2019a) ...
    Setting up libdatetime-perl:amd64 (2:1.50-1+b1) ...
    Setting up libdatetime-format-strptime-perl (1.7600-1) ...
    Setting up libdatetime-format-builder-perl (0.8100-2) ...
    Setting up libdatetime-format-iso8601-perl (0.08-2) ...
    Setting up git-mediawiki (1:2.20.1-2) ...
    Processing triggers for install-info (6.5.0.dfsg.1-4+b1) ...
    Processing triggers for menu (2.1.47+b1) ...
    Processing triggers for desktop-file-utils (0.23-4) ...
    Processing triggers for mime-support (3.62) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for libglib2.0-0:amd64 (2.58.3-2) ...
    Processing triggers for libc-bin (2.28-10) ...
    Processing triggers for systemd (241-5) ...
    Processing triggers for man-db (2.8.5-2) ...
    Processing triggers for qubes-core-agent (4.0.45-1+deb10u1) ...
    Processing triggers for dbus (1.12.16-1) ...
    Setting up tcl (8.6.9+1) ...
    Setting up tk (8.6.9+1) ...
    Setting up git-gui (1:2.20.1-2) ...
    Setting up gitk (1:2.20.1-2) ...
    Setting up git-all (1:2.20.1-2) ...
    Errors were encountered while processing:
     exim4-config
     exim4-base
     exim4-daemon-light
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    user@host:~$ sudo apt install git-all 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    git-all is already the newest version (1:2.20.1-2).
    The following packages were automatically installed and are no longer required:
      acl bsdtar curl-scripts fuse gdisk gpg-bash-lib gvfs-common gvfs-libs inotify-tools libarchive-tools libatasmart4
      libblockdev-fs2 libblockdev-loop2 libblockdev-part-err2 libblockdev-part2 libblockdev-swap2 libblockdev-utils2
      libblockdev2 libfuse2 libgck-1-0 libgcr-base-3-1 libinotifytools0 libntfs-3g883 libparted-fs-resize0
      libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libudisks2-0 ntfs-3g pv spectre-meltdown-checker
      virt-what vrms wmctrl
    Use 'sudo apt autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    3 not fully installed or removed.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue? [Y/n] y
    Setting up exim4-config (4.92-7) ...
    /usr/sbin/update-exim4.conf: 467: /usr/sbin/update-exim4.conf: /usr/sbin/exim4: Operation not permitted
    Invalid new configfile /var/lib/exim4/config.autogenerated.tmp, not installing 
    /var/lib/exim4/config.autogenerated.tmp to /var/lib/exim4/config.autogenerated
    dpkg: error processing package exim4-config (--configure):
     installed exim4-config package post-installation script subprocess returned error exit status 1
    dpkg: dependency problems prevent configuration of exim4-base:
     exim4-base depends on exim4-config (>= 4.82) | exim4-config-2; however:
      Package exim4-config is not configured yet.
      Package exim4-config-2 is not installed.
      Package exim4-config which provides exim4-config-2 is not configured yet.

    dpkg: error processing package exim4-base (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of exim4-daemon-light:
     exim4-daemon-light depends on exim4-base (>= 4.92); however:
      Package exim4-base is not configured yet.

    dpkg: error processing package exim4-daemon-light (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     exim4-config
     exim4-base
     exim4-daemon-light
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    user@host:~$

remove qubes-core-agent dependency on initscripts
https://github.com/QubesOS/qubes-issues/issues/5133

Details

Impact
High

Event Timeline

TNTBOMBOM triaged this task as Normal priority.Jun 24 2019, 12:05 AM
TNTBOMBOM edited projects, added Whonix 15; removed Whonix.
TNTBOMBOM changed Impact from Needs Triage to High.

Workaround:
While this should be fixed, note, meanwhile the following works perfectly well for general use of git (I did not ever had any situation where I was missing any features):

sudo apt install git

Another workaround:

sudo apt install git-all --no-install-recommends

Another workaround with full git-all functionality that does not break Whonix:

sudo apt install git-all runit-systemd

git-all also breaks Qubes Debian buster template. @marmarek

user@debian-10:~$ sudo apt install git-all
...
The following packages will be REMOVED:
  colord dbus-user-session gnome-sushi gvfs gvfs-backends gvfs-daemons
  libpam-systemd nautilus network-manager network-manager-gnome packagekit
  packagekit-tools policykit-1 policykit-1-gnome
  qubes-core-agent-network-manager qubes-vm-recommended rtkit systemd-sysv
  udisks2
...

git-all Recommends: git-daemon-run.

git-daemon-run Depends: on runit.

runit Recommends: runit-sysv.

runit-sysv is incompatible with Whonix and Qubes Debian template. Even sudo apt install runit-sysv --no-install-recommends would uninstall some Whonix or Qubes packages.

It is because runit-sysv Depends: on sysvinit-core, which Conflicts: with systemd-sysv.

systemd-sysv Depends: on systemd.

Some of Whonix / Qubes packages Depends: on systemd.

A workaround could be installing package runit-systemd by default but I don't know yet what it does so in theory it could cause more issues than it solves.

Clean solution (even if theoretic)...?:

  • Maybe Whonix / Qubes packages having a Depends: on systemd is considered a bug?
  • Perhaps this could be a Debian packaging bug? Maybe they'd say that's just the limitations of APT and the sysadmin has to deal with these for example by using --no-install-recommends?
TNTBOMBOM added a comment.EditedJul 25 2019, 3:33 PM

but it doesnt happen on plain debian-qubes template , any idea why?

Actually it did , just tested again. So o think leaving systemd dependency better.

remove qubes-core-agent dependency on initscripts
https://github.com/QubesOS/qubes-issues/issues/5133

Patrick updated the task description. (Show Details)Jul 25 2019, 5:08 PM
Patrick edited projects, added Whonix; removed anon-meta-packages, Whonix 16.