Page MenuHomePhabricator

Tor Browser in whonix-ws-14 based VMs sometimes blocks JavaScript on first start
Closed, ResolvedPublic

Description

Expected behavior: Tor Browser does not block JavaScript by default

Observed behavior: Tor Browser in whonix-ws-14 based AppVMs in Qubes OS 4 blocks JavaScript on first boot (in ~50% of the cases)

This issue can not be reproduced with vanilla Tor Browser on a non-whonix machine so the assumption is that it is somehow related to Whonix even though Whonix does not aim to make changes to Tor Browser, but minor changes to its configuration are required by Whonix (i.e. SOCKS settings, startpage, ..) that could be triggering this issue.

I also noticed the file "~/.tb/first-boot-home-population.done" which suggests that whonix does something on first boot that it does not everytime (which would explain why this happens only on first boot if at all). The issue is particularly annoying on dispVMs based on whonix-ws-14 because there every boot is the "first boot".

Tor Browser Version: 8.0.6 (it also happened with 8.0.5)

https://forums.whonix.org/t/tor-browser-in-whonix-blocks-javascript-only-when-started-for-the-first-time-and-in-dispvms/6843

Details

Impact
Normal

Event Timeline

Patrick triaged this task as Normal priority.Feb 16 2019, 9:50 AM
Patrick changed Impact from Needs Triage to Normal.
Patrick claimed this task.Feb 16 2019, 1:54 PM

I also noticed the file "~/.tb/first-boot-home-population.done" which suggests that whonix does something on first boot

It copies Tor Browser from root image /var/cache/tb-binary/ to TemplateBasedVM (that includes DispVMs) user home folder.

https://github.com/Whonix/tb-updater/blob/master/usr/lib/tb-updater/first-boot-home-population

https://www.whonix.org/wiki/Dev/git#grep_Whonix_source_code

So by the time /usr/bin/torbrowser starts it might not be fully copied to user home folder yet.

This is now fixed.

https://github.com/Whonix/tb-starter/commit/7827ef3ffc61d1c85724d5bbc4ed5b7003b3c882

Updated packages in stable-proposed-updates and testers repository. Will flow to stable as per usual process.

Patrick closed this task as Resolved.Feb 16 2019, 1:56 PM