Page MenuHomePhabricator

Mouse cursor rarely works on KVM Whonix WS 14.0.1.3.8
Open, NormalPublic

Description

I'm connecting to VM with just virt-viewer (not using virt-manager). There is a bug T872 with similar symptoms, stating that the problem was virtio mouse. I checked xml config - only ps2 mouse is present.
Versions:
Whonix 14.0.1.3.8 (fresh install, not an upgrade from previous version)
virt-viewer 7.0
libvirt 5.0.0
qemu 3.1.0
host kernel 4.20.7
Steps to reproduce:
a) Boot Whonix Workstation VM with virsh (virsh start Whonix-Workstation)
b) Connect to VM with virt-viewer. One of the following then happens:

  1. VM's display is completely unresponsive to mouse cursor. Restarting virt-viewer doesn't help at all.
  2. It is possible to click on start menu button then press Esc to hide start menu. Then VM's display becomes completely unresponsive to mouse cursor. Restarting virt-viewer doesn't help at all.
  3. VM's display behaves normally. This happens like 1 time out of 10 VM boots.

Details

Impact
Normal

Event Timeline

WhoCares created this task.Feb 9 2019, 2:33 PM
Patrick assigned this task to HulaHoop.Feb 9 2019, 3:59 PM
Patrick added a project: KVM.
HulaHoop closed this task as Resolved.Feb 21 2019, 9:33 PM

What distro are you using?

Unfortunately if it's a rolling or bleeding edge one, you will occasionally run into problems like this, but on the upside they will be fixed quickly (and replaced with other new problems?)

I can't reproduce this on Debian stable and even if I could I can't do much about it. I recommend you switch to stable for a better experience. There is no tangible benefit of running newer packages at this time. No killer features in testing packages that I would sacrifice stability for.

I recommend you report this to upstream so they can fix it before its part of stable.

I'm using Arch.
All the software versions (libvirt, QEMU, virt-viewer, kernel) are deemed stable upstream (by their respective developers, not by Debian folks).

WhoCares reopened this task as Open.Mar 1 2019, 7:26 PM

I reopened this because KVM page (https://www.whonix.org/wiki/KVM#Arch_Linux) explicitly mentions Arch as a host OS.
If someone here is using Arch as well, maybe you guys can reproduce this after all. Also see my previous comment.

Patrick triaged this task as Normal priority.Sat, Apr 6, 8:22 PM
Patrick changed Impact from Needs Triage to Normal.