Page MenuHomePhabricator

mouse does not work in Whonix-Workstation 14 KVM
Closed, InvalidPublic

Description

I have a cursor, clicking does nothing, UI elements do not react to mouse over.
Gateway works as expected, both are clean installs with no changes in the guest or domain XML.

Whonix version: 14.0.0.7.4

Host:
Compiled against library: libvirt 4.0.0
Using library: libvirt 4.0.0
Using API: QEMU 4.0.0
Running hypervisor: QEMU 2.11.1
Ubuntu 18.04.1

Details

Impact
High

Event Timeline

toxdosvyqydtexlr triaged this task as High priority.
Patrick assigned this task to HulaHoop.

It could be the VM is confused because apparently there are two types of mice attached. I assumed that by adding virtio-mouse it would override and replace the emulated one. Turns out its not this way and I went ahead and reverted this config which should be effective in the next release.

Please remove virtio input devices mouse and keyboard from VM hardware settings and test again.

made no difference.

also, Gateway works fine, Workstation does not.

$ virsh dumpxml Whonix-Gateway | grep input
    <input type='mouse' bus='virtio'>
      <alias name='input0'/>
    </input>
    <input type='keyboard' bus='virtio'>
      <alias name='input1'/>
    </input>
    <input type='mouse' bus='ps2'>
      <alias name='input2'/>
    </input>
    <input type='keyboard' bus='ps2'>
      <alias name='input3'/>
    </input>

$ virsh dumpxml Whonix-Workstation | grep input
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
HulaHoop closed this task as Invalid.EditedOct 13 2018, 12:37 AM

Sorry not reproducible on my end. May be related to the fact that you are running a non-standard setup with custom compiled binaries. By running packages from your distro there is a higher chance that bugs are more visible for more people and more likely to be fixed.

Note that Debian is more stable than Ubuntu and has more resources to produce fixes in a more timely way.

By running packages from your distro there is a higher chance that bugs are more visible for more people and more likely to be fixed.

I am.

$ apt-cache policy libvirt-bin libvirt-daemon libvirt0 qemu-system-x86 qemu-kvm
libvirt-bin:
  Installed: 4.0.0-1ubuntu8.5
  Candidate: 4.0.0-1ubuntu8.5
  Version table:
 *** 4.0.0-1ubuntu8.5 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0.0-1ubuntu8.2 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     4.0.0-1ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
libvirt-daemon:
  Installed: 4.0.0-1ubuntu8.5
  Candidate: 4.0.0-1ubuntu8.5
  Version table:
 *** 4.0.0-1ubuntu8.5 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0.0-1ubuntu8.2 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     4.0.0-1ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
libvirt0:
  Installed: 4.0.0-1ubuntu8.5
  Candidate: 4.0.0-1ubuntu8.5
  Version table:
 *** 4.0.0-1ubuntu8.5 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.0.0-1ubuntu8.2 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     4.0.0-1ubuntu8 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
qemu-system-x86:
  Installed: 1:2.11+dfsg-1ubuntu7.5
  Candidate: 1:2.11+dfsg-1ubuntu7.6
  Version table:
     1:2.11+dfsg-1ubuntu7.6 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
 *** 1:2.11+dfsg-1ubuntu7.5 100
        100 /var/lib/dpkg/status
     1:2.11+dfsg-1ubuntu7.3 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     1:2.11+dfsg-1ubuntu7 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages
qemu-kvm:
  Installed: 1:2.11+dfsg-1ubuntu7.5
  Candidate: 1:2.11+dfsg-1ubuntu7.6
  Version table:
     1:2.11+dfsg-1ubuntu7.6 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
 *** 1:2.11+dfsg-1ubuntu7.5 100
        100 /var/lib/dpkg/status
     1:2.11+dfsg-1ubuntu7.3 500
        500 http://security.ubuntu.com/ubuntu bionic-security/main amd64 Packages
     1:2.11+dfsg-1ubuntu7 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Works fine:
Whonix-Gateway 13
Whonix-Gateway 14
Whonix-Workstation 13
Windows 7
Windows 10
Ubuntu 14.04
Ubuntu 16.04
Ubuntu 18.04
Debian 9.5

Does not work:
Whonix-Workstation 14

I'm fairly sure the problem is not me.