Page MenuHomePhabricator

coyIM
Open, NormalPublic

Description

coyIM has the advantage of being designed around Tor support, forcing encryption by default, including INSTANT XMPP account generation and for using a secure backend written in Go.

The disadvantage is it uses OTR which lack offline message support.

Last blocker to inclusion from Stretch repos was that we needed to confirm stream isolation support which it likely does.

https://packages.debian.org/stretch/coyim

Details

Impact
Normal

Event Timeline

HulaHoop triaged this task as Normal priority.Jun 25 2018, 2:20 PM
HulaHoop created this task.
Patrick updated the task description. (Show Details)Aug 8 2018, 10:38 AM

So what task remains for this DNS/TransPort leak testing?

Done. Connects successfully even when Transparent TCP/DNS disabled on gateway. So it uses stream isolation out of the box and is ready for prime time.

Old pull request:
https://github.com/Whonix/anon-meta-packages/pull/8

Please re-base off master so it doesn't erase recent changes by you(?)

Could you please send a new pull request?

Done: https://github.com/Whonix/anon-meta-packages/pull/10

Offtopic: There is a PR from Algernon for intramfs packages, what s their status?

Patrick closed this task as Resolved.Aug 17 2018, 9:23 PM
Patrick claimed this task.

Was the wrong package now after CLI / GUI packages split. Anyhow. Done now.

I've improved the package descriptions btw just now to include if it is a GUI or CLI package.

Offtopic: There is a PR from Algernon for intramfs packages, what s their status?

https://forums.whonix.org/t/whonix-for-arm64/1788/58

Patrick reassigned this task from Patrick to HulaHoop.Aug 17 2018, 9:27 PM

also another reason why CoyIM wont come back in the near future:

https://twitter.com/FreeOlaBini

He was a major dev/creator of CoyIM but not the only one.

@Patrick were you able to reproduce this? I wasn't

@Patrick were you able to reproduce this?

Yes.

Patrick edited projects, added Whonix 16; removed Whonix 15.Jun 14 2019, 3:30 PM

Problem has since been reported and fixed upstream. Let's look into re-including by Bullseye.