Page MenuHomePhabricator

Tor 0.3+ does not work on QubesOS (but Tor 0.2.9.10 works)
Closed, InvalidPublic

Description

Had been using Whonix GW Testing on Qubes OS 4.0 RC2 without any issue.
Following Whonix GW Testing update, sys-whonix would no longer connect or bootstrap.
Tested on another PC with same result.

Reinstalled Qubes OS and the default sys-whonix proxy based on the whonix-gw Stable template worked fine.
I upgraded this template, rebooted it and the sys-whonix proxy, and they continue to work fine. Tor version is Tor 0.2.9.10 (unrecommended).

Cloned whonix-gw Stable template and set it to Stable Proposed Updates repo and upgraded, rebooted, etc.
Cloned whonix-gw Stable template and set it to Testing repo and upgraded, rebooted, etc.

Created a sys-whonix proxy based on Stable Proposed Updates template.
Created a Testers sys-whonix proxy based on Stable Proposed Updates template.

The sys-whonix proxies based on the Stable Proposed Updates template and the Testers templates will not bootstrap or connect to tor network.

The two sys-whonix proxies that will not bootstrap or connect are both using the newer Tor 0.3+.

Any ideas?

Details

Impact
Needs Triage

Event Timeline

ons2ibypk5 renamed this task from Whonix GW Tor 0.3+ does not work on QubesOS (but Tor 0.2.9.10 works) to Tor 0.3+ does not work on QubesOS (but Tor 0.2.9.10 works).Nov 11 2017, 1:02 PM
ons2ibypk5 updated the task description. (Show Details)
Patrick claimed this task.

Cannot reproduce. See https://forums.whonix.org/t/long-wiki-edits-thread/3477/349. For support requests, the forum is better suited.