Page MenuHomePhabricator

sort out meta packages compatiblity with Qubes 3.2 and Qubes R4.0
Closed, ResolvedPublic

Details

Impact
High

Event Timeline

Patrick created this task.Jun 29 2017, 6:45 PM

From part (<< 4.0.0-1) what does << do?

The qubes-core-agent (>= 2.1.60), a few lines earlier can and should be kept for compatibility?

According to debian policy, << is the syntax for "strictly older than".

As for qubes-core-agent >= 2.1.60 - Qubes 2 is EOL, but technically this dependency isn't implied by any other here. So yes, I'd keep it.

Merged.

Please see comment:
https://github.com/Whonix/qubes-whonix/pull/4#issuecomment-328585445

I guess once ^ is sorted, I gotta upload the new package.

marmarek added a comment.EditedSep 11 2017, 9:45 PM

Done: https://github.com/Whonix/qubes-whonix/pull/5
Note that I've created PR against Whonix13 branch instead of master intentionally. While it should be mergeable to master too, it would be good to have it in Whonix13. The current version from master branch is already incompatible with Whonix 13.

Merged.

Note that I've created PR against Whonix13 branch instead of master intentionally. While it should be mergeable to master too, it would be good to have it in Whonix13. The current version from master branch is already incompatible with Whonix 13.

I couldn't merge / cherry-pick it. Manually emulated.

https://github.com/Whonix/qubes-whonix/commit/9a8d4b94865efceec7928d5498260a44241d96b2

Could you check please the master branch has it all? (Because that will go into Whonix 14.)

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

In T697#14525, @Patrick wrote:

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

Does this sort out this Qubes 4.0 Qubes-Whonix blocker?

In T697#14525, @Patrick wrote:

Merged.

Note that I've created PR against Whonix13 branch instead of master intentionally. While it should be mergeable to master too, it would be good to have it in Whonix13. The current version from master branch is already incompatible with Whonix 13.

I couldn't merge / cherry-pick it. Manually emulated.

https://github.com/Whonix/qubes-whonix/commit/9a8d4b94865efceec7928d5498260a44241d96b2

Could you check please the master branch has it all? (Because that will go into Whonix 14.)

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

Looks good.

In T697#14526, @Patrick wrote:
In T697#14525, @Patrick wrote:

Whonix13 branch i.e. qubes-whonix 5.7.2.1-1 uploaded to Whonix jessie-proposed-updates repository.

Does this sort out this Qubes 4.0 Qubes-Whonix blocker?

I'll build a new template and test again. But from my testing of my local build before making PR, it should.

Patrick closed this task as Resolved.Sep 12 2017, 2:54 PM
Patrick assigned this task to marmarek.