Page MenuHomePhabricator

Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix
Closed, ResolvedPublic

Description

As reported at https://github.com/QubesOS/qubes-issues/issues/2650 by Holger Levsen.

Qubes OS version (e.g., R3.2):

R3.2

Affected TemplateVMs (e.g., fedora-23, if applicable):

whonix-gw

Expected behavior:

pulseaudio and vlc should not be installed in sys-whonix.

Actual behavior:

#2648 is the issue suggesting to split out a qubes-gui-agent-pulseaudio package out of qubes-gui-agent.

once this has been done the whonix-workstation package should depend on qubes-gui-agent-pulseaudio
and the whonix-gateway package should not (and then vlc and pulseaudio wouldnt be installed in sys-whonix.)

See also:
https://github.com/QubesOS/qubes-issues/issues/2648

We need a Whonix-Workstation meta package (existing or new?) to depend on pulseaudio-qubes.

https://forums.whonix.org/t/need-to-add-pulse-audio-for-tor-browser-7-0-1/4032/6

Details

Impact
Normal

Event Timeline

Patrick created this task.Feb 26 2017, 7:05 PM
Patrick edited projects, added Whonix 14; removed Whonix 15.May 30 2017, 11:31 PM
Patrick renamed this task from pulseaudio and vlc should not be installed in sys-whonix to install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.Jun 29 2017, 6:20 PM
Patrick updated the task description. (Show Details)
Patrick removed Patrick as the assignee of this task.

It fits well into package qubes-whonix-workstation-packages-recommended.

https://github.com/Whonix/qubes-whonix/blob/master/debian/control#L69

So I'll add to Depends:...?

pulseaudio-qubes | qubes-gui-agent,

The first part pulseaudio-qubes is for Qubes R4 support and the latter part | qubes-gui-agent is for Qubes R3.2 compatibly.

Does that look alright to you? @marmarek

Will that really works for 4.0? There is also qubes-gui-agent package, so it isn't clear to me that pulseaudio-qubes will really be installed. Perhaps pulseaudio-qubes | qubes-gui-agent (<< 4.0.0)?

True, my suggested solution might work for new builds but might not work
for R3.2 -> R4 upgrades.

Perhaps pulseaudio-qubes | qubes-gui-agent (<< 4.0.0)?

That wouldn't work for Qubes R3.2, since there is neither
qubes-gui-agent (<< 4.0.0) (highest available version is
3.2.18-1+deb9u1) nor pulseaudio-qubes.

Do you see any solution?

(highest available version is 3.2.18-1+deb9u1)

Exactly, this do meet qubes-gui-agent (<< 4.0.0) criteria - version is lower than 4.0.0.
Not sure how to force installing pulseaudio-qubes on 3.2->4.0 upgrade (instead of keeping old qubes-gui-agent).

Not sure how to force installing pulseaudio-qubes on 3.2->4.0 upgrade (instead of keeping old qubes-gui-agent).

It's a manual, documented process anyhow. Can be listed here:

https://www.whonix.org/wiki/Upgrading_Whonix_13_to_Whonix_14

Patrick renamed this task from install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix to Qubes R4: install pulseaudio-qubes in Whonix 14 for audio support / pulseaudio and vlc should not be installed in sys-whonix.Mar 7 2018, 1:46 AM
unman added a subscriber: unman.Apr 4 2018, 5:27 PM

@Patrick
Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

The current Whonix-14 templates from Qubes unstable correctly have no vlc in whonix-ws, although vlc libraries, vlc-data and vlc-plugins are still included.
Whonix-ws has the vlc binaries and browser-plugins, as expected.

I think that's enough to close this, unless all traces of vlc should be purged from the gw? If it was necessary to remove the vlc backend, it would be possible to replace it with phonon4qt5-backend-null

Patrick closed this task as Resolved.Apr 6 2018, 8:34 AM
Patrick claimed this task.
In T641#15836, @unman wrote:

Installation of pulseaudio-qubes is now included in the 13-14 upgrade guide under Qubes-Whonix instructions.

Very good.

I think that's enough to close this, unless all traces of vlc should be purged from the gw?

That would be good for feasible (dependency hell). Can be covered in T786.

If it was necessary to remove the vlc backend, it would be possible to replace it with phonon4qt5-backend-null

Created T786 for it.