Page MenuHomePhabricator

install accessibility tools by default
Closed, InvalidPublic

Description

As per Whonix - Advice on Accessibility for a Debian Derivative, the following packages should be installed by default.

gnome-orca espeakup brltty brltty-speechd brltty-x11 console-braille florence dasher kdeaccessibility kvkbd kmousetool kmag kmouth jovie xbrlapi festival qt-at-spi

Makes the images ~ 73 MB bigger. (Installed using apt-get --no-install-recommends.)

Installing these by default probably makes only sense in Non-Qubes-Whonix, as in a Qubes environment, these would have to be installed by default in dom0, I think.

(These should be installed by default, and manual installation is not so useful, because the people requiring these tools in the first place, are not capable to install them by themselves without help of a third person.)

[Especially for users requiring to use Tor Bridges, and a Non-Qubes-Whonix-Gateway, this poses a difficult to overcome obstacle. Recently got a mail by such a user.]

Details

Impact
Normal

Event Timeline

Patrick created this task.Dec 19 2015, 9:16 PM
Patrick raised the priority of this task from to Normal.
Patrick updated the task description. (Show Details)
Patrick set Impact to Normal.
Patrick added subscribers: Patrick, HulaHoop, marmarek and 2 others.
Patrick changed the task status from Open to Review.Jan 8 2016, 6:39 PM
install more accessibility tools by default

anon-shared-kde-accessibility

gnome-orca espeakup brltty brltty-speechd brltty-x11 console-braille florence dasher kdeaccessibility kvkbd kmousetool kmag kmouth jovie xbrlapi festival qt-at-spi

https://github.com/Whonix/anon-meta-packages/commit/dc2b97efef5af2ae67a4134480d1eb32f50da809

Patrick closed this task as Resolved.Apr 28 2016, 3:35 AM
Patrick claimed this task.

brltty is problematic, because it opens a local listener port on 4101. (T448#10396)

/var/log/syslog spam host brltty[204]: file system mount error: usbfs[brltty-usbfs] -> /var/run/brltty/usbfs: No such device:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845496

espeakup systemd unit restart fails during jessie to stretch upgrades.

no longer install accessibility tools by default due to issues

no longer depend on anon-shared-kde-accessibility

https://phabricator.whonix.org/T457

https://github.com/Whonix/anon-meta-packages/commit/cd23ef486c1f404f9903f2605fdc2b5972c3bd2e

Patrick closed this task as Invalid.Sep 11 2018, 7:41 PM