Page MenuHomePhabricator

versioned Depends: tor (>= 0.2.7.3) once based on Debian Stretch
Closed, ResolvedPublic

Description

https://github.com/Whonix/anon-gw-anonymizer-config/blob/70b9436b9178e0b8b79b42625ec7ff2886be017b/debian/control#L17-L25

## Workaround: Not using versioned 'Depends:' on 'tor'.
## Ideally we would depend on 'tor (>= 0.2.7.3)' because we are using,
## 'KeepAliveIsolateSOCKSAuth' which is not available in earlier versions.
## It would break the build. Debian jessie only has 'tor' '0.2.5'. Which is
## the only available repository at anon-gw-anonymizer install time.
## (1700_install-packages) The Tor Project's deb repository with Tor 0.2.7 is
## added only afterwards. (2300_run-chroot-scripts-post-d) This workaround can
## likely be removed once Whonix is based on Debian stretch.
Depends: anon-shared-helper-scripts, tor, sudo, anon-base-files,

Details

Impact
Normal

Event Timeline

Patrick created this task.Nov 24 2015, 1:29 PM
Patrick updated the task description. (Show Details)
Patrick raised the priority of this task from to Normal.
Patrick set Impact to Normal.
Patrick added subscribers: Patrick, HulaHoop.