Page MenuHomePhabricator

Qubes-Whonix Whonix-Workstation TemplateVMs block access to (torified) open internet
Closed, InvalidPublic

Description

As of Qubes-Whonix 10, Qubes-Whonix Whonix-Workstation TemplateVMs are capable to connect to open internet (over Tor).

Is it a bug or feature?

I guess we should keep connections to torproject.org (Tor Browser updates, perhaps anonymity/connectivity check), Debian, Whonix and Qubes repository allowed, but block the rest? Similar to Qubes' default Fedora TemplateVM?

Details

Impact
Normal

Event Timeline

Patrick created this task.Jul 3 2015, 7:21 PM
Patrick raised the priority of this task from to Normal.
Patrick updated the task description. (Show Details)
Patrick set Impact to Normal.
Patrick added subscribers: Patrick, nrgaway, marmarek and 2 others.
Patrick renamed this task from Qubes-Whonix Whonix-Workstation TemplateVMs block access to open internet to Qubes-Whonix Whonix-Workstation TemplateVMs block access to (torified) open internet.Sep 8 2015, 6:49 PM
Patrick edited projects, added Whonix 14; removed Whonix 13.Mar 18 2016, 4:21 PM
Patrick added a comment.EditedMar 18 2016, 4:25 PM

As discussed in sys-whonix does not yet function was Qubes FirewallVM, in future TemplateVMs will not be needing their own NetVM anymore.

Rather than implementing this ticket Qubes-Whonix Whonix-Workstation TemplateVMs block access to (torified) open internet, the solution to this ticket is to wait for Qubes to implement the following tickets:

Patrick closed this task as Invalid.Aug 16 2016, 12:38 AM
Patrick claimed this task.

Duplicate of T466.