Page MenuHomePhabricator

rads skip mechanism
Closed, ResolvedPublic

Description

rads is of no use for Qubes. The systemd unit currently does not get started there.

Its systemd unit is currently using

ConditionPathExists = !/usr/lib/qubes-whonix

This isn't a great agnostic solution.

Also /usr/lib/ram_adjusted_desktop_starter/display-manager-dpkg-post-invoke should not be run on Qubes.

Details

Impact
Normal

Event Timeline

Patrick updated the task description. (Show Details)May 15 2015, 5:30 PM
Patrick added a project: rads.
Patrick set Impact to Normal.
Patrick added subscribers: Patrick, nrgaway.
Patrick created this task.
Patrick claimed this task.
Patrick raised the priority of this task from to Normal.

pull request for qubes-whonix, skip rads:
https://github.com/nrgaway/qubes-whonix/pull/2

Added another commit to the pull request.

skip rads systemd service on qubes - https://phabricator.whonix.org/T306:
https://github.com/adrelanos/qubes-whonix/commit/683b8de3d606a0caebfdcc9021f22836225890b6

systemd unit: removed non-agnostic 'ConditionPathExists = !/usr/lib/qubes-whonix', this will be implemented in the qubes-whonix package - https://phabricator.whonix.org/T306:
https://github.com/Whonix/rads/commit/9d1605db7e44f61cb8b590165bf9c26eb56606cf

Patrick changed the task status from Open to Review.May 15 2015, 10:07 PM

I have already reviewed your PRs and there is nothing I can see to prevent build errors and I have also merged them into a test branch I am using for building this weekend. Will merge into master once everything confirmed working.

Will this cause a problem if included in Whonix10 branch since the codebase is still currently the same. If it will cause an issue I will only merge it into Whonix11 branch for now and not 10

Yes. This is supposed for Whonix >= 11 only. (Hence, only using 'Whonix 11' tag, not 'Whonix 10' tag.)

Patrick closed this task as Resolved.May 17 2015, 3:34 PM